Jump to content

problems printing with HP 4V with MS2000


allen1y
 Share

Recommended Posts

I hope someone can help me with this annoying problem. Everytime I re-boot my pc my printer doesn't work. They way I get it to work is to go to control panel/system/hardware/device manager/port(LPT1) and then update driver. After that it prints fine until the next re-boot then I have to go through the whole process again. I have tried downloading a new driver but that didn't work either. A solution would be gratefully appreciated.

Thanks

Link to comment
Share on other sites


Something you can try to see if it's the driver causing this (it usually is, but it doesn't hurt to check):

1. Completely uninstall the driver (and any other software that was installed with the printer) and remove the print queue - once done, reboot the machine and make sure it's all removed

2. Install the printer again, but this time do not install any software - simply use the add/remove printers wizard, and choose the generic HP Laserjet 4 driver built into the OS as the driver

3. Print a test page

If you are able to print a test page to your printer over the LPT1 port, you need to consider using a different driver. HP isn't known for their great drivers (at least not the low-end, home user stuff - the high-end business stuff is *usually* OK).

Link to comment
Share on other sites

It sounds like your issue is with the printer port LPT1, is it in ECP mode?

I would recommend uninstalling the printer, then going into DM and uninstalling LPT1, reboot and go into the bios (don't let windows start), Completely disable LPT1, then restart Windows so it can "see" LPT1 is gone.

Now reboot and reenable LPT1 with these (typically default) settings:

Port 03F8

IRQ 7

DMA 3

ECP mode enabled

Boot into Windows and the port should be detected as new hardware and installed, check DM and make sure there are no resource conflicts. Use the Add Printers wizard to install the 4V with the MS driver, print a test page, and then reboot to make sure it stays put (it should).

If this doesn't work let us know how & where it failed, as this will help to pinpoint the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...