Jump to content

[Bug] UserAccount management from Lite 1.2 RC


Recommended Posts

I've managed to make my second unattended XP Pro DVD which took a lot of time, but it's very complete now.

The problem is that I cant finish it because of a bug in nLite's useraccount management.

I want to have two accounts enabled.

- Username: Administrator (automatic login, Administrator Rights)

Fullname: SomeOne1

Password: xxxxxxxx

- Username: Guest (Enabled, restricted rights)

Fullname: SomeOne2

At some point during the creation of the unattended install I thought I wanted to use three accounts

the extra account was deleted in a later stage of the development of the unattended installation.

- Username: Somebody

Fullname: SomeOne3

I'm nearly finished with customising and heve waisted 8 DVD because I always get the alert at login that probebly the wrong username and password are used and the user selected for automatic login (in nLite) can not log in.

While trying to fix this I found something strange.

When I look in the "User Accounts" part from Control Panel there are two user accounts.

- "Administrator"

- "Guest"

If I use UserPasswords2 there are three different accounts.

- "Administrator"

- "Guest"

- "Somebody"

The somebody account was deleted from the install quite a while ago (with nLite).

Now the stangest part.

If I look in "%SYSTEMDRIVE%\Documents and Settings\" there are two (not hidden) user account directories.

- "All users" (not realy a user account, I know)

- "SomeOne1" (Which is the Full Name of the user account I've created and deleted in the process of developing the XP installation).

I've tried many different things but realy don't want to start over again. Is there a way to fix this manualy in the installation source?

Edited by Bram77
Link to comment
Share on other sites

It won't delete added users if you rerun it and delete there.

Basically I understand your frustration but you'll have to remake it all at once next time.

And keep your copy of unattended iso before any editing, that's common rule even if you edit something manually.

Link to comment
Share on other sites

I've started over from scratch. It wasn't that much work actiualy because most software I made my own unattended installations for at first run with batch scripts.

Thank you for the tip, I'll keep that in mind.

Link to comment
Share on other sites

Is it me, or does the account creation in nLite not work like it should? The account type is not set correctly. I set them to administrator, but they are set as normal users which gives me lots of troubles...

Can someone confirm this?

Other thing, nuhi, could you add a feature to set the user account pictures?

Link to comment
Share on other sites

I'm testing my config with an english XP Professional SP2 Dell cd. And I replace the $OEM$ folder with my own stuff ofcourse.

After some rebuilding I can confirm this. It also seems to forget the passwords I set for the extra users.

Could you help me fix this in my image? I don't have time to wait for the next release of nLite to have this fixed. It's the last thing before my install cd is ready..

Oh and to set your own account pictures, don't overwrite the rigstry key. It does not work. Best solution is to overwrite the bitmaps in "%SystemDrive%\Documents and Settings\All Users\Application Data\Microsoft\User Account Pictures\".


Mind you I'm constantly working with the same local copy of the install cd, modified to my needs. Everytime I need to make a change to the $OEM$ folder I run through all nLite steps and rebuild the setup files and create the image. Last few times I removed the previously added user accounts, but in the last builds it created those accounts anyway...?!

Edited by pkoppelaar
Link to comment
Share on other sites

hi nuhi! trying out 1.2 RC does not allow me to put different (or none for others) organization/company names ... meaning if there is 1 in Admin, all the rest has this though ... by the same circumstance, if there is nothing specified in Admin's org/co. name, there is nothing too for the others ...


btw, i do not if it's me but RC 1.2 runs faster time :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...