Jump to content

Cannot start WinPE 2.0 Build 5536 (and RC1)


Recommended Posts


i made me a cd which should load WinPE 2.0 but this fails.

after the ntoskrnl.exe boot screen is finished the following error appear:

"Windows PE cannot start because the actual SYSTEMROOT directory (X:\Windows) is different from the configured one (X:\$Windows.~BT\Windows). This can be configured with peimg /targetpath..."

But when i use the original boot.wim from the vista build is works. so say me plz whats wrong :(

Mounted the image with the following command:

ximage /mountrw "F:\WINPE\WINPE2.0-ISO\sources\boot.wim" 1 "C:\mounted"

compressed with the following command:

ximage /capture /compress maximum /boot "F:\WINPE\Build 5536" "C:\boot.wim" "WINPE20"

my folder structure of the cd:






hope anybody can help me

Edited by Sereby
Link to comment
Share on other sites

the winpe.wim and boot.wim from the waik are the same (150mb!)

i used the boot.wim from vista build 5536 (only ~100mb)

if i use the unmodifyed boot.wim from this build it works and it starts the setup window. and if i use the winpe.wim and change this one it works too :( but i want the newer one and the smaller one

Edited by Sereby
Link to comment
Share on other sites

M$ says the following in the winpe.chm file of the opk CD:

Windows PE Build Environment

A Windows PE package contains the following:

Filename Description


Default Windows PE boot image. This image contains all components and cannot be customized.


A customizable Windows PE image, also called the base image.

although opk CD is not WAIK, but I think M$ do not wish you to modify a file originally named "boot.wim", you may try to remove some components of winpe.wim(of the new version), hope to cut down 50MB :P

Edited by jungle_warrior
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

with rc1 its still the same problem! but if i use peimg to change the path it does start but it only show up a cmd window and dont start the setup.exe! if i start it manual it aborts after selecting the os (unattended install)

i tried a lot but i dont get it working! can anybody help me? i used rc1 waik with vista rc1 both in german

Link to comment
Share on other sites

  • 11 months later...

Digging into the registry I found this was because of 1 registry key. It's located here:

[HKEY_LOCAL_MACHINE\pe_software\Microsoft\Windows NT\CurrentVersion\WinPE]

What is needed is to change InstRoot to the directory below your Windows directory.

So, to enable this to work you'll need to set InstRoot=X:\

Why does Microsoft do this? So you can use a WinPE install off a harddisk with all the associated expanded files as oppoesd to a large WinPE image.

At least, that's what I've figured :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...