Jump to content

winnt.sif works from floppy, but not I386 folder

Recommended Posts

I am having trouble getting an install CD that I created to recognize that I have placed winnt.sif in the I386 folder. I placed the winnt.sif file in the I386 folder, and have all my files in the $OEM$ folder. I use BBIE to extract the cd boot image, and use CDIMAGE to create a bootable CD ISO. The problem is not a boot problem - the CD boots just dandy. The problem is that the windows setup ignores the fact that winnt.sif is present on the CD, and it starts a standard attended install.

Before you ask, I am positive that the file is not named winnt.sif.txt; and I also know that the winnt.sif file is working just fine, because when I copy the file from I386 folder on the CD directly to a floppy, and insert the floppy when the installer starts loading, it works perfectly. :angry:

I have made CDs before using utilities like XPCREATE, but this time I am performing the process manually, and I can find NO difference between the placement of the files on the CD I created before with XPCREATE, and the one I am creating now...

I can figure one of three things might be a problem...

1) It could be that because I am just dropping the winnt.sif file in the I386 folder, (which is putting it at the end of the other files on the physical disk) that it gets burned to a different place in the ISO where the Windows setup is not expecting it.

2) Another possibility is that some other file or folder on the source CD (received from directly from MS Fullfillment) is keeping winnt.sif from running. I have found no mention in this forum to remove and files from the install to get the unattended install to work.

3) One last item I considered is that winnt.sif may be a case sensitive file, but the XPCREATE CD I have that does work, has winnt.sif in all lower case, just like my new CD.

Other than this, I have completely run out of ideas... Has anyone else encountered this problem??? :}


Link to comment
Share on other sites

Could you please post your winnt.sif file (without the product key of course) so we may look and see if the problem lies there.

1) This doesn't matter.

2) Just make sure no "winnt.si_" file is in the I386 directory.

3) This doesn't matter.

Link to comment
Share on other sites


I found the problem! It is because of reason 3 (the file winnt.sif MUST be WINNT.SIF)

The problem was that I was using the -d (don't force lowercase filenames to uppercase) flag with CDIMAGE.EXE to make the ISO. As soon as I dropped this flag, it made an ISO that recognized the winnt.sif file!

I tried renaming the file to all uppercase, and once again used the -d flag, and again, the ISO booted and started the automated install.

I checked the working CD I have and found that winnt.sif is lowercase, but upon inspecting it with IsoBuster, the good CD has an additional TOC with file names that are all uppercase, including an entry for WINNT.SIF.

So.. If you ever have this problem, then save yourself a few headaches and try capitalizing WINNT.SIF.

Finally time to go to bed!

Edited by rommager
Link to comment
Share on other sites

i've only ever used lowecase for filenames, but then again don't use the -d flag, but well spotted as i'm sure that'll happen to somebody else.

P.S: any way we can add this nugget to the unattended.msfn.org site??

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...