Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
lordmontie

Edit txtsetup.sif So You Don't Need To Move Files Like WIN51

Recommended Posts

Hello everyone! I'm pretty **** new here and to Mulit-Boot DVDs. I just (finally) bought a DVD-Burner! Now I want to create a few Mulit-Boot DVDs of WinOS's and some Linux OS's. Here we're only concerned about Win ... So I have read through this form and other guides to make a Win Mulit-Boot DVD and I'm getting the hang of everything now. There is a big problem that I don't like about Multi-Boot DVDs ... the root directory of the DVDs are filled with crap files which makes everything a mess! :no: After looking at txtsetup.sif to modify it, I've found a fix that I haven't seen posted or noted anywhere! Normally you are suppose to change the SetupSourcePath in the [setupData] section:

[SetupData]

*snipped blank lines*

SetupSourcePath = "\"
MajorVersion = 5
MinorVersion = 1
DefaultPath=\WINDOWS

But what I found was if you go up a few lines you see this:

jpndir = "\langpack\jpn"
kordir = "\langpack\kor"
chtdir = "\langpack\cht"
chsdir = "\langpack\chs"


MUI_PRIMARY_LANG_ID_DIR = "system32\mui\0009"


cdname = "Windows XP Professional CD-ROM"
productname = "Windows XP Professional"


bootname1 = "Windows XP Professional SP2 Setup Boot Disk"
bootname2 = "Windows XP Professional SP2 Setup Disk #2"
bootname3 = "Windows XP Professional SP2 Setup Disk #3"
bootname4 = "Windows XP Professional SP2 Setup Disk #4"
bootname5 = "Windows XP Professional SP2 Setup Disk #5"
bootname6 = "Windows XP Professional SP2 Setup Disk #6"

cdtagfile = "\win51ip"


cdtagfilei = "\win51ip"

cdtagfilem = "\win51mp"

boottagfile1 = "\disk101"
boottagfile2 = "\disk102"
boottagfile3 = "\disk103"
boottagfile4 = "\disk104"
boottagfile5 = "\disk105"
boottagfile6 = "\disk106"

spcdname = "Windows XP Professional Service Pack 2 CD"
spcdtagfilei = "\win51ip.sp2"

cd2name = "Windows XP Professional CD2"
cd2tagfilei = "\win51ip2"


[SetupData]

*snipped blank lines*

SetupSourcePath = "\"
MajorVersion = 5
MinorVersion = 1
DefaultPath=\WINDOWS

Now look closely to the lines cdtagfile, cdtagfilei, cdtagfilem, spcdtagfilei, and cd2tagfilei. They are all looking for those defining files that would be in the CD's root directory but are now located somewhere else. Instead of copying those files need to the DVD's root directory, just add that same path that you added to SetupSourcePath before the '\*file*' on each of those lines. Also you see the boottagfile* lines? Most of these are in your OS's new boot folder (4 lettered that matched the modified setupldr.bin file), so just add that folders path (should be '\' + Folder Name) in front of the '\disk***' lines.

... so now it would be this:

jpndir = "\langpack\jpn"
kordir = "\langpack\kor"
chtdir = "\langpack\cht"
chsdir = "\langpack\chs"


MUI_PRIMARY_LANG_ID_DIR = "system32\mui\0009"


cdname = "Windows XP Professional CD-ROM"
productname = "Windows XP Professional"


bootname1 = "Windows XP Professional SP2 Setup Boot Disk"
bootname2 = "Windows XP Professional SP2 Setup Disk #2"
bootname3 = "Windows XP Professional SP2 Setup Disk #3"
bootname4 = "Windows XP Professional SP2 Setup Disk #4"
bootname5 = "Windows XP Professional SP2 Setup Disk #5"
bootname6 = "Windows XP Professional SP2 Setup Disk #6"

cdtagfile = "\SYSTEMS\WINXP\PRO_SP2\win51ip"


cdtagfilei = "\SYSTEMS\WINXP\PRO_SP2\win51ip"

cdtagfilem = "\SYSTEMS\WINXP\PRO_SP2\win51mp"

boottagfile1 = "\XPPR\disk101"
boottagfile2 = "\XPPR\disk102"
boottagfile3 = "\XPPR\disk103"
boottagfile4 = "\XPPR\disk104"
boottagfile5 = "\XPPR\disk105"
boottagfile6 = "\XPPR\disk106"

spcdname = "Windows XP Professional Service Pack 2 CD"
spcdtagfilei = "\SYSTEMS\WINXP\PRO_SP2\win51ip.sp2"

cd2name = "Windows XP Professional CD2"
cd2tagfilei = "\SYSTEMS\WINXP\PRO_SP2\win51ip2"


[SetupData]

*snipped blank lines*

SetupSourcePath = "\SYSTEMS\WINXP\PRO_SP2\"
MajorVersion = 5
MinorVersion = 1
DefaultPath=\WINDOWS

I've already tried it and it's working like a charm! Now the only problem that I have is when the sys file 'cmdide.sys' is loaded, it can't be found and I get an error and a restart! Now sure what's going on with this! I've checked for the file and it's there, I've used the BootFolder.exe program to get the Boot Folder and I've also done the 'winnt32.exe /noreboot' way too. I still get an error saying that 'cmdide.sys' can not be found! Any help here? Thanks and hope this works / helps + you like it!

Share this post


Link to post
Share on other sites

While that is true, it's more work to edit all the txtsetup.sif files than it is to simply copy some 0KB files to the root of your DVD, especially if - like me - you have a LOT of options on your DVD. For example, I have 11 different choices for OS installs and each one is done twice (once for regular setup and once for preinstall). That's 22 different times I'd have to edit the txtsetup.sif to modify those lines. It's just not worth it. Not a bad idea, just not good for everyone.

Share this post


Link to post
Share on other sites

Jito463,

That is true ... I really didn't think about that at all. But then again, since I'm a neat freak I hate having the root cluttered up with these small files when it takes an extra 20 seconds to make the modifications needed ...

By the way, does anybody know why I'm having an issuse with setup not finding the 'cmdide.sys' file during the text mode boot. I've tried it many different ways but nothing works, please I need some help on that! Thanks,

Share this post


Link to post
Share on other sites

Thanks lordmontie!

Gonna use it. I'm a neat freak too, I guess ;)

For your cmdide.sys, I suspect its a file corruption. Are you sure you have the correct cmdide.sy_ file in both, the relevant I386 folder, & the BOOT folder as well? Is it missing in one of the 2 places? Have you checked in BOTH places, to see if its corrupted in any way? (rename to .CAB & try extracting)

Do post back, I'd like to see if it was solved or not....

Share this post


Link to post
Share on other sites

prathapml,

it took me awhile to see your reply, for some reason I never got an email about it ... I've checked both places where cmdide.sys should be, in my Boot Folder and in the i386 folder, and they are there! I've changed the extenstion to .cab and opened with WinRAR without any problems! I see a file size for cmdide.sys to be 6,656 bytes. I also checked the cmdide.sys files on my iso image after I make it to make sure that there wasn't a problem there, but they extract with same size so they should be good ...

I'm don't know what is going on, but I'm going to try rebuilding all my files and see if that fixes the problem ... any other ideas? Thanks,

Share this post


Link to post
Share on other sites

[EDIT]Sorry, for some reason it keeped messing up when I was posting the reply! I guess there was a slow-down or lots of users ...[/EDIT]

Edited by lordmontie

Share this post


Link to post
Share on other sites

[EDIT]Sorry, for some reason it keeped messing up when I was posting the reply! I guess there was a slow-down or lots of users ...[/EDIT]

Edited by lordmontie

Share this post


Link to post
Share on other sites

Try changing the lines below back to their default. You shouldn't need to mess with these as I never alter them and you don't need them on the root so it might be messing up the install:

boottagfile1 = "\XPPR\disk101"

boottagfile2 = "\XPPR\disk102"

boottagfile3 = "\XPPR\disk103"

boottagfile4 = "\XPPR\disk104"

boottagfile5 = "\XPPR\disk105"

boottagfile6 = "\XPPR\disk106"

Share this post


Link to post
Share on other sites

Jito463,

I had this same problem with a normally configured txtsetup.sif file ... but anyways I tried returning them to their defaults and I still get the same problem ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...