Jump to content

WinPE + nForce4 SATA (Not RAID) = 0x7B


Recommended Posts

I'm having the most amazing trouble integrating nForce4 SATA drivers into WinPE. First of all, I've seen about 20 posts about getting nvraid to work. I don't have a RAID array and all I need are the nvata.sys drivers. Unfortunately in the nVidia nForce4 pack, the "sata_ide" driver (the one I'm pretty sure I have to use) has no txtsetup.oem file. I've tried every means of integrating nvraid/nvatabus.sys drivers:

1: creating a new folder in system32, "nvraid" and referring it from winpeoem.sif - didn't work

2: every method listed on this thread: http://www.msfn.org/board/index.php?showtopic=38717 including:

A: Copy .sys files to i386/system32/drivers, editing txtsetup.sif by adding PNP strings to [HardwareIdsDatabase], and filenames of .sys files in [sCSI.Load]

B: Simply putting the .sys file in [sCSI.Load] and the name of the device in [sCSI]

3: Manually inserting the F6 disk provided by the motherboard mainfacturer as well as those downloaded from nVidia and 3rd party sites

I've done everything short of messing with the driverpacks, because

A: I don't want to blow up my image so much

B: Nobody has clearly listed a means of incorporating it into WinPE

I'm using SBS Server 2003 OPK CD version of WinPE with a build sourced from a Windows XP 32-bit SP2 CD. Built by copying WINPE\*.* and Tools\arch\*.* to a folder and running MKIMG. I create the ISO after integrating drivers with "OSCDIMG.EXE -betfsboot.com -n -h C:\winpe\xp32b C:\winpe\winpe32.iso" which successfully creates the ISO. My deployment server is running Linux TFTPD-HPA and PXE/DHCP, serving up NTLDR, startrom.0 (startrom.n12) and ntdetect.com (all from SBS 2003 SP1 CD). I upload the ISO file to the tftproot folder and winnt.sif serves it up via RAMDISK. The image loads successfully and it gets to "Starting windows preinstallation environment" and then fails miserably with 0x7B every time. I've been able to get as far as "Please Wait..." with some of the methods I've tried as listed above, but regardless, it will subsequently hang for an unspecified period on that screen and then show an 0x7B blue screen.

I think that driverpacks or bartpe or "uA CD" may hold the answers I need, but I'm not familiar with any of these third party tools and it would be moot regardless, as I'm only using 32-bit windows to try my methods. The actual implementation will require me to be able to install x64. Essentially, I may only need a simple txtsetup.oem file for nvata.sys. I know somebody said that there was something like this in one of the driver packs. Would anybody be willing to explain how I could acquire this file?

Edited by jcampbell
Link to comment
Share on other sites

I think this link is useful for you:


If there's other directories there, just add it as shown separated by commas. There’s one special case for a particular mass storage driver - the NVIDIA NForce Storage Controller requires the following addition:

[massstoragedrivers.append]nvfix = classpnp.sys

Good luck !

Edited by OcTroN
Link to comment
Share on other sites

Unfortunately this did not work : ( I've also tried copying classpnp.sys up to system32 as somebody suggested.

Still pulling my hair out. I've posted questions to nVidia and Microsoft people, but apparently WinPE is so deep in the rabbit hole, nobody wants to acknowledge its existence. I can just see the guys at nVidia right now:

"And then the dude goes: I'm not using XP, I'm using PE"

"AHAHAHA, the poor guy is using ME, and he can't even get the name right, what a weiner!"

Apparently nobody deploys nForce4 boards in large batches with RIS (sarcasm). This must be some kind of voodoo trade secret. Somebody's boss out there is going "HOLY CRAP, that was difficult, NOONE MUST KNOW. From this day forth, WE will be the only people who can deploy nForce4 boards in bulk, MUAHAHAHA!" I guess everybody is just using imaging these days.

I'm having this much trouble with 32-bit PE, I get an eerie feeling once I get this fixed, it's going to be another fight getting the 64-bit drivers to work.

I swear if I ever get this working I'll post a huge tutorial here and spam it all over the System Builder forums at Microsoft. They seem to think their KBXXXXX articles and CHM files have all the answers, but nobody has updated that s*** since last century. "64-bit" means "IA64" in all Microsoft docs I've read.

nVidia's philosophy towards all of this seems to be "we've already answered everybody's questions, there are no unique problems. Here is a document for a wholly unrelated issue, it should point you in the right direction." And since everybody's problems have all stemmed from integrating NVRAID drivers into an XP CD, they think that's what my problem is and I just don't know what I'm talking about.

Trying to explain to them my problem is actually NVATA in PE reminds of the scene in the Simpons where Marge is in Australia, trying to order coffee at a bar.

Marge: "Coffee please."

Bar Tender: "One beer coming right up."

M: "No no, Coffee"

B: "Beer"



Edited by jcampbell
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...