Jump to content

SP2 - CDShell - 2 XP Installs


Recommended Posts

I am familiar with how to make slipstreamed and slipstream unattended cd's. Familiar with NLite and RyanVM packs and Gosh's method of reducing source on the above and having it work fine.

Now I'm making a disc with CDShell where I have 2 copies of XP SP2. One for Desktop - Unattended (PROD) and Laptop - Unattended (PROM) with seperate cd-keys and other winnt.sif settings.

Making a directory structure that matches the Multi-Boot DVD's guide (even though this is going on cd-rw) or even using my own directory structure (listed below) I still get the same issue/error. I've tried regular slipstream with "winnt32.exe /dudisable /noreboot" obtained BOOT and I've even set (in PROD and PROM) full copies of a full reduced source installer and even the documented full original SP2 I386 dir copied.


The error is this. CDShell operates fine. Does the splash screen, I press enter to boot, choose one of 2 menu options (as there are only two, and they chain to the appropriate .DAT file. setupldr.bin and txtsetup.sif modified appropriately, winnt.sif in existance or not doesn't seem to matter) and it launches the windows setup where it copies and initializes the driver base prior to drive selection.

I then choose the drive where I can do (have tried to do) any of the following:

Installing to the existing partition, with a format,

Deleting existing partition and installing with a format.

It deletes partitions fine. But in the format stage, doing either full NTFS or a Quick NTFS I get the same error:

"Setup cannot format the partition.

Your computer may not have enough memory to perform this operation, or your Windows XP CD-ROM may contain some corrupted files.

Setup cannot continue. To quit Setup, press F3"

Now, if I told it to erase the partition and try booting of the disc again and try assigning the now empty partition to install on, it say's it needs to verify my systems ability due to the lack of an exisitng OS and wants me to put in an NT3.51, 4.0, Win 98, ME or 2K cd before it will proceed.

This only happens with the cd that I created under the multi-boot instructions, even following them to the letter (to the extent that I'm only putting 2 XP installers on it and nothing else). Again, a regular slipstreamed cd, NLite'd cd with RyanVM, Reduced Source SP2 w/RyanVM all install fine in Attended or Unattended.

Any ideas how to get this working? :(

System Specs:


AMD Sempron 2400 @ 1.66 Mhz @ 333 FSB

Kingston matched 256x2 (Total 512) mb DDR400 @ 333, BIOS detected default's by SPD.

ATI Radeon 9200

WD 7200rpm 40gb HDA

Sony 52x24x52 cd-rw

**EDIT: Verbatim error message added.

Link to comment
Share on other sites

A quick workaround:

partitioning your hdd with a extern tool like symantec partition magic or acronis utilities. Then put your AIO-cd into computer and start it. On driver selection, choose the existing primary ntfs partion and no formating.

Link to comment
Share on other sites

A wonderful and workable idea. In the end I've just scrapped the idea of a multi-boot cd. Mainly because in explicitly following the directions or even in adjusting them according with what I need, it still doesn't work. *shrug*

Glad that someone thought to reply with anything though.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...