Jump to content

TabletPC unattended install


 Share

Recommended Posts

Hi,

I'm trying to install a TabletPC with my unattended Windows XP Pro installation.

During the GUI-fase of the setup at minute 26 it asks for the file tpgwlnot.dll and searches for the directory c:\$win_nt$.~ls\cmpnents\TABLETPC\i386

But this directory is not present at the target machine. However, it is in place at my distribution-share.

I am using a Tablet XP ProductID, so that's good. :D

I found something on this forum about txtsetup.sif:

[sourceDisksNames.x86]

1 = %cdname%,%cdtagfilei%,,\i386

2 = "%cd2name%","%cd2tagfilei%",,\cmpnents\tabletpc\i386

3 = "%cd2name%","%cd2tagfilei%",,\cmpnents\mediactr\i386

4 = "%cd2name%","%cd2tagfilei%",,\cmpnents\netfx\i386

This guy said i should change %cd2name%","%cd2tagfilei% to %cdname%,%cdtagfilei%

I did that, but still the same result. :angry:

Does anyone know what this %cd2tagfilei% means?, is this maybe a file that i can find on the root of CD2?

Has anyone got ideas about how to solve this problem?

Regards,

Alexander

Link to comment
Share on other sites


If you use the /makelocalsource switch, add :all at the end:

winnt32.exe /makelocalsource:all

otherwise the cmpnents folder fails to be copied.

These pages might lead you on the right track:

http://www.microsoft.com/technet/prodtechn...y/tpcdploy.mspx

http://www.microsoft.com/technet/prodtechn...y/sitpcdep.mspx

I have not tried this myself though, so I have no further tips, sorry. :blushing:

//EDIT: It looks like you have to use the /makelocalsource:all switch

Note: If the makelocalsource switch is not used, the cmpnents directory will not be copied by setup and you will receive file copy errors during the setup process.
Link to comment
Share on other sites

Hi,

I found the solution for the problem.

I'm using winnt.exe, not winnt32.exe, winnt.exe does not support the /makelocalsource:all option.

However it has got the option /2 which is equivalent to /makelocalsource:all

So it works now, the tablet pc is installed nicely. :D

Regards,

Alexander :lol:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...