Jump to content

chkdsk errors


dman
 Share

Recommended Posts

I am getting some strange errors from chkdsk while windows xp pro is running (ntfs). This is output from cmd

C:\Documents and Settings\DMAN>chkdsk

The type of the file system is NTFS.

Volume label is Local Disk.

WARNING!  F parameter not specified.

Running CHKDSK in read-only mode.

CHKDSK is verifying files (stage 1 of 3)...

File verification completed.

CHKDSK is verifying indexes (stage 2 of 3)...

Index verification completed.

CHKDSK is recovering lost files.

CHKDSK is verifying security descriptors (stage 3 of 3)...

Security descriptor verification completed.

CHKDSK is verifying Usn Journal...

Usn Journal verification completed.

CHKDSK discovered free space marked as allocated in the

master file table (MFT) bitmap.

Correcting errors in the Volume Bitmap.

Windows found problems with the file system.

Run CHKDSK with the /F (fix) option to correct these.

  39062015 KB total disk space.

  29140288 KB in 134425 files.

    43856 KB in 14530 indexes.

        0 KB in bad sectors.

    232411 KB in use by the system.

    65536 KB occupied by the log file.

  9645460 KB available on disk.

      4096 bytes in each allocation unit.

  9765503 total allocation units on disk.

  2411365 allocation units available on disk.

C:\Documents and Settings\DMAN>

so I run chkdsk /f at boot: no errors. Even ran it from BartPE: no errors.

reboot and run with windows running, same errors.

This machine is meticulously clean of viruses and malware. I even scanned for alternate data streams and found none. anyone have any ideas...? I cant find anything except a few vague references about sp2 and calling MS, no answers. Is there anything better than chkdsk?

Link to comment
Share on other sites


Thanks for reply Marsden. same results though. Heres the rub... at boot or from bartPE everything is fine, no errors. only running chkdsk from running windows has errors. I even did a full backup, reformatted the partition and did restore so I know FS is good, but as soon as I start windows the problem is back. It seems like it must be some running program that is causing this. It doesn't seem to be causing any problems crash wise, but it's bugging me.

Link to comment
Share on other sites

You cannot run chkdsk correctly while windows is running as well. I presume your running it from a command prompt within Windows right? What you want to do is go into "My Computer" right click the drive you want to chkdsk, then select properties. Once in the properties, select the "Tools" tab, and in the "Error-Checking" section, click the button that says "Check Now", and just follow the prompts and restart. Once windows restarts the system, it will run chkdsk before fully loading the operating system.

Link to comment
Share on other sites

yes, thank you, but as I stated.. i have run at boot time and also from bartPE with no errors. i know it cant fix while windows is running, but it shoulden't be showing errors either.

Link to comment
Share on other sites

Pre sp1 the ontrack and norton equivelants and running from the recovery console showed no errors on my dell. Running chkdsk normally always showed errors similar to the ones you had noted. This stopped with sp1. There might not be anything wrong with your disk and this might be a bug peculiar to your system. If you can get or dl a trial of the norton utilities and run their version of chkdsk and if it show no errors It might just be a bug.

Link to comment
Share on other sites

Thanks george,

norton doesn't seem to give demo of systemworks. everything that I don't need, they have. I hate to buy it for something that isn't really causing a problem... especially because not sure if there IS a problem. maybe if I see it on sale.

Link to comment
Share on other sites

i'm having the same problem but when i get a problem the system randomly restarts,no blue screens not nuttin,it never did it before,it's clean of viruses n such,i've even tried different drivers n such,still the same then i got a blue screen PFN_LIST_CORRUPT

STOP:0x0000004E (0x0000008F,0x00021C09,0x00017449,0x00000000)

that means memory but my memory works fine,even a reinstall does not help or a repair,could it be nvidia drivers sound drivers or windows installer 3.1?would installing home edition instead of pro do help?my power supply is a 480 watt and it works.

Link to comment
Share on other sites

If you're running a program, that is doing something as oposed to having it open and just siting there or changing or moving a file while chkdsk is running you'll get an error then or usually you'll get a chkdsk message that it can't proceed any further. Something has to change while it's running. There is a utility "Disk Checker 3.0 BETA 10" RS Software Lab, I don't know if it uses it's own chkdsk or ms's. But it has a trial period so dl it and try it. Try running chkdsk from the recovery console. You'll have to set up your bios so the xp disk can boot. If you have xp home you'll have to set up an administrator password to be able to access it. The chkdsk /f switch is chkdsk /r it is independent of the os and when I was having the problems pre sp1 the check always came up fine.

Description of the Windows XP Recovery Console

CHKDSK

chkdsk drive /p /r

The chkdsk command checks the specified drive and repairs or recovers the drive if the drive requires it.The command also marks any bad sectors and it recovers readable information.

You can use the following options:

/p : Does an exhaustive check of the drive and corrects any errors.

/r : Locates bad sectors and recovers readable information.

The more I think about it I remember Dell telling me to use a maxtor utility that came on their utility disk and the disk was coming up clean (I believe the new version is called PowerMax). If it's ok from the recovery console it's probably a bug.

Link to comment
Share on other sites

@George,

thanks for detailed reply. I appreciate your time. I have run all chkdsk switches from BartPE, which is same as recovery console (i.e. c: is inactive) and always get no errors. Only while running in windows is there errors. I tried "Disk Checker" that you suggested and it reported no errors, so I'm just going to chalk it up as a bug in chkdsk.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...