Jump to content

Unattended install through network


Recommended Posts

Dos boot disks were once the only way to kick off a network install. However, as many of you noticed, this involves a VERY slow file copy process. Smartdrive does speed things up significantly but still nowhere near optimal performance.

Microsoft has listened to OEM requests (namely, that many systems don't ship with floppy drives anymore, and installs are slow and error-prone) and provided a new solution to replace Dos boot disks: Windows Preinstallation Environment, or WinPE for short.

WinPE is the modern equivalent of a Dos boot disk. It's a stripped down version of Windows that boots from a CD-ROM into a windowed environment with a command prompt. I cannot express how fantastic WinPE is. First and foremost, you get a native 32 bit network stack and the same NTFS driver Windows uses. This means that installs are fast, fast, FAST. My unattended installs went from 45+ minutes to less than 15.

Unfortunately, WinPE is not free, although Bart has made a toolset available that will allow you to create a functionally equivalent "BartPE" disc. I highly recommend checking it out and reading up on the WinPE forum here at MSFN.

Link to comment
Share on other sites


Hi, thx for your answer but i still need some help.

-JohnGrugh ... i tried with the t switch and i still have the same problem .... win xp do not see my ntfs partition, i tried in fat32 and it<s ok ... but my file in $oem$ are copied but some are too long and are rename with a ~1 ... etc.. so many of my driver/script fail to install.

i<ll might try bart modboot today

-baliktad... I tried using BartPE method .... i got my bartcd to work everything is fine ... i thing ... but when i enter in PE environnement ... i need to install windows ... i map a drive z: the lauch my install.bat (\i386\winnt.exe /s:\i386 /u:\I386\winnt.sif) but i got an error saying than winnt is not a win32 valid application :( i dont want to install from setup ... i want my unattended install to work alone

Ps: Sorry for my bad english

Link to comment
Share on other sites

When you boot with BartPE or WinPE, you need to use Winnt32.exe to start Windows installation.

Example:

winnt32.exe /unattend1:C:\local\unattend.txt /s:c:\local\source\i386 /udf:%computername%,Z:\unique.udb /syspart:c: /tempdrive:c: /debug4:c:\local\debug.log 
/noreboot /copysource:lang /dudisable

rem To restart PC: kill nu2 to restart from BartPE. "Exit" restarts WinPE
if "%RamDrv%"=="B:" pskill.exe nu2menu.exe
exit

Available command line options are explained in Winnt32.hlp

Link to comment
Share on other sites

Hmmm ... thx alot for the fast answer .... that was a stupid question :blushing:

Sorry but i have anoter one :( ; now i get an error : Winnt32.hlp not found .... but Winnt32.hlp is there in the same folder ... i have never touched it

thx in advance.

Link to comment
Share on other sites

Hi guys, I read the post and I did all following your instructions but I'm prompted by the following error after the setup has been launched:

Windows XP requires a hard drive volume with at least 2046 megabytes of free disk space. [...omissis...]Setup cannot continue. Press Enter to exit.

Ok, but I've created and formatted using gdisk a 4 giga fat 16 partition labelled C:, so there's plenty of space...where could be my mistake?

Link to comment
Share on other sites

Be carefull , when you use network installation you have two contraint :

1) long file name on $OEM$ , windows process copy with winnt.exe doent use long file name

2) space on c: drive , if your $OEM$ folder size are more what 2046 Gb winnt.exe indicate you have not space on c: drive

Solutions :

1) rename the files on the bacth file on runonce

2) use a share drive to stock your application or use a d: drive to copy the application

regards

Link to comment
Share on other sites

Ok, thanks, so what should I do exactly intead of using a gdisk command?

Furthermore my $oem$ is 1,50 gb size, the whole installation is 2,3 gb size and (to be honest) I didn't care about the 8.3 DOS files rule, but my setup doesn't start it stops once it performs the first check on the c: drive.

With gdisk I used the following syntax:

gdisk 1 /y /del /all

it deletes on the 1 drive all partitions

gdisk 1 /y /cre /pri /-32 /sz:2047 /for /q

it create one primary partition and then format it as fat16

Link to comment
Share on other sites

I forgot to mention that I also tried formatting a 4096 mbytes partition with FAT32 filesystem without any success, windows setup still prompt me that there's not enough space on the hard drive the following is the syntax used:

gdisk 1 /y /cre /pri /x /sz:4096 /for /q

Link to comment
Share on other sites

Ok guys, I've made a couple of attempts,

now, still using gdisk :D , I'm able to launch setup but I'm still obtaining the same **** error, that's what I'm doing:

I have a first bat

lh smartdrv

gdisk 1 /y /del /all

gdisk 1 /y /cre /pri /for /q

Then I have a C: drive with a FAT32 partition (not too bad, isn't? especially if I will convert later on an NTFS partition)

After that step I launch a second batch on my mapped network drive:

\i386\winnt.exe /s:\i386 /u:\i386\unattend.txt

But all that I can obtain is an annoying error which tells me that I don't have enough space...the important thing is that if I launch from i386 winnt.exe WITHOUT any parameter it works and it starts the installation!!! Obviously is not my preferred behaviuor since I want an unattended setup ...ideas??? Suggestions? Now I'm at a no-return point.... :blushing:

Link to comment
Share on other sites

Now it's a sort of diary...anyway I've found my mistake (it was just a blank space) and I corrected so it seems that the installation has been launched but I have a couple of errors during the setup, it seems that it soesn't read my unattend.txt, I will continue tomorrow, now I' m tired.

Link to comment
Share on other sites

Yes, it is, although it has perfectly worked with my DVD, now I guess that I should correct some mistake or something else, anyway I'll let you know :blushing:

P.S. I also have an horrible suspect, since I made in my original unattended some add-on using Nlite I guess that the program has changed something since during the graphical part of the setup I'm prompted for a couple of files missing...any advice?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...