Jump to content

How to reinstall "Automatic Update" component?


Recommended Posts

Hello everybody,

I removed the "Windows Automatic Update" component via an unatteneded script during Windows XP + SP1a setup, and now I want to install this component but I cannot find it in the Add/Remove Windows Components, I even went to the reg key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Oc Manager\Subcomponents" and set the value "autoupdate" to 1 and rebooted but in vain.

Any ideas?

Thanks in advance.


Link to comment
Share on other sites

The script may have simply turned off the service associated with Updates.

go to Start > Run and type services.msc and right click the Automatic Updates service and click Properties and change it from disabled to Automatic.

Also check to make sure the Background Intelligent Transfer Service and Event Log service are on Automatic.

When you are finished it would be best to restart your system and then visit Microsoft Updates to see if you have been successful.

Link to comment
Share on other sites


Thanks for your reply. I actually did what you have just mentioned and I have NOT found the "Automatic Updates" service and also no key for this service under the reg "Services" key.

It seems that the component has not been installed at all.

BTW, I used this in my answer file:




Link to comment
Share on other sites

Man, yes it was this line to reinstall the component, many thanks for pointing this out.

However, after I installed the component, I got the message "Windows Update service is unavailable" on the "Automatic Updates" tab and I followed the tip and started the the "Automatic Updates" service. The message disappeared and the "Automatic Updates" tab looked normal except one thing: all controls are in the disabled state, I even restarted the machine to make sure but the same result.

Any more ideas? Really appreciate your help!


Link to comment
Share on other sites

Hi all

I'm glad I found the inf call .... I will see if it works in a autoinstaller package.. That I'm working on for the update site...

I'm sticking with Sp1 for a while and I just got done going over this with a fine tooth comb...

When I load SP1 with all the updates the windows update site takes a dump all over you on the first go around...

What I did was use the au.inf from SP2 to install the auto update into SP1....

the run the wuweb.inf to install the active x component....

when you go the web site for the first time you go start to the page that says express or custom...

Give me a couple of days and i'll post a way....

I have the files all trapped I just need to proof the installer....

To get Sp1 update site to work right you need the new files,,,

LOL windows XP Sp2 uses the same files as SP1 ....

What I meant is after you get the active X updates downloaded all the files are the same... in both versions.....

SP1 was set up to use the old version V4 site....

if you have all the files you can try to run the AU.inf from the SP2 package...

put all the files in the same foilder as the Au.inf from Sp2...

there is a few that it ask for a loaction just make a sub i386 folder and put the file in it and hit go..

when you get done it will be all lined up reboot and do your checks,,,

The SP1 inf files are fubared up...

and the SP1 au.inf file is for the old version v4 site,, and the wusetup.inf doesn't work either.....

Link to comment
Share on other sites


Thanks for taking the effort to reply, however, I thought something is missing or broken after installing via the au.inf, so I decided to go to the "Windows Update" site, it asked to install the components for WU v5 and did so, and even manged to install the latest critical security updates and the "Automatic Update" tab aslo has been updated with the new colored shield icons.

But what still drives my crazy is that all controls on this tab are disabled!!!!!!!!!!!!!!!!

Again any thoughts?!!!!!!!!!!!!!!!!!!!

Thanks all.


Link to comment
Share on other sites

OKay, I've found the cause of the disabled controls, it turned out that I added a reg tweak (reg policy) that disabled auto updates :), it was something like this:


I changed the value to 0 and restarted, and everything looked normal.

Sorry for bothering you all and thanks for help.


Link to comment
Share on other sites

No problem mate glad to see you worked it out,,,

Just to let you know I'm bailing out of this auto install of updates and software...

It is a nice idea,, But it doesn't work...

To many conflicts,,,

So enjoy after you play you will see why...

I'm going to go back to old way of installing by numbers,,,

It takes a little longer but it works,,,

I'll just use the win file to load serial ...

the rest I'm going to leave default...

Bye and good luck...

even doing the svcpack hotfixes in accordance to the Microsoft site...

didn't work...

when you copy the files to the I386 folder like the article says that even cause coinflicts...


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...