Jump to content

W2k3 SBS Remote Desktop Problem


 Share

Recommended Posts

Hi guys,

I'm having problems with the Remote Desktop utility. I basically just CAN'T get a connection running. I have read every thread, have tried many options and settings but nothing works.

-I have set the options in My Computer >> Properties >> Remote

-The account I'm currently trying to log on to is an Admin

-Terminal Services are installed

Here's the error I get (Translated from French)

The clien could not connect to the remote computer.

The remote connections might be disabled, or the distant server might be too busy to accept new connections.

It is also possible that you cannot connect because of network problems.

Try later and blabla administrator.

Can someone point out a check list of some kind, or any usefull ideas? Thank you very much. (I'll be back on Monday to check out the help, if any :) )

Link to comment
Share on other sites


Both the local host and the remote client need port 3389 open to allow UDP traffic.

Remote access has to be allowed on the remote client.

Win2K3 can remote into an XP client but not Win2k and earlier. Any earlier client with the proper RDP client software can remote desktop into Win2K Server, XP and Win2K3 server.

Link to comment
Share on other sites

  • 1 month later...

Hello,

First off it sounds like you have already enable remote desktop connectivity on your desktop. If you are using a WIN2K or earlier desktop you will need to install the RDP client from Microsoft.

Second as the other post said, you will need to make sure your desktop and server can establish a connection over TCP (not UDP) port 3389.

Third, you will need to make sure your server is set to allow RDP connections. You do this the same way you do in WinXP by right-clicking My Computer, choosing Properties, clicking on the Remote tab and making sure "Allow users to connect remotely to this computer" is checked.

That should do it for you.

tguy

Link to comment
Share on other sites

Are you trying to access from the lan or from home?

I agree with tguy, Check the port is open, remote desktop protocol uses TCP 3389, and in the Properties of the server check in the remote tab that remote desktop is enabled (not remote assistance!!!!).

Also if you've already done that, check out in the server the Terminal Services configuration manager (in the administrative tools) to check if any connection there is still active and log it off, remember that if you don't select logoff the connection remains active.

how many concurrent connections is your server configured to accept?, terminal services in administrative mode only supports 2 concurrent connections, besides the connections made by the clients to access resources or authenticate.

you can get the terminal services client from windows/system32/clients/tsclient folder in win 2003 and install it in the WS

Link to comment
Share on other sites

  • 3 weeks later...

I am having a similar issue with RD. I am working on a network with a 2K server PDC, and 2K Server proxy running ISA. I am working on a rollout of laptops and on my "list" is to have the laptops connect via RD to the users desktops. I keep ending up with the error that no terminal servers are available. I was not aware that I needed to have TS installed. Laptops and desktops are running XPSP2. THX JK

Link to comment
Share on other sites

  • 2 weeks later...

hey guys,

heres my problem i need to conect to my server using a udp port insted of a tcp port because all of the tcp ports at my school are blocked so iv been lookin this up for a good 2 or 3 weeks now and got no where figured this was worth a try i know there are the ways to change port numbers and all by typing in the ip adress in the remote desktop conection page so i was tryin to find out if you could change the port it runs through even though its built in defult is tcp

thx

Link to comment
Share on other sites

Hello. Actually, in the SBS server packages, Remote Terminal Services is disabled and cannot be enabled, to my knowledge. You can connect to the terminal services using remote desktop WITHIN the network, but not from outside (via port 3389). The reason for this is that most SBS servers are also Domain Controllers, and Microsoft doesn't feel that it would be secure to allow this type of remote connection to a Domain Controller. Hope this helps.

Link to comment
Share on other sites

Clearly cribner, you do not know what you are talking about...

I remote into my SBS 2003 network almost every day. Either through RDP or when checking mail via OWA and Exchange 2003.

This screen is available in every version of Win2K3 server, SBS 2003, Enterprise, Standard and Web Editions.

RDP is encrypted and secure. That coupled with a valid user account and strong password and it does not get any more secure.

post-35-1101864701_thumb.jpg

Link to comment
Share on other sites

Hi Guys,

I completely forgot about this thread after a while, but I finally got it working.

Marsden, you're right; you can use RD on SBS. I, too, use it every day. I just walk around the office with my laptop and connect whenever I need to access the server. It's quite a wonderful tool ;)

Need to get on with my other problems now, later !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...