Jump to content

winnt.sif being ignored


Recommended Posts

Hi there, I am a noob to unattended installations, and I just don't know what is going wrong. I did everything that the official unattended guide told me to do to create the answer file, I also added extras for what I wanted it to do. I put the winnt.sif file in the i386 folder of my slipstreamed sp2 folder, then i created an iso image of the slipstreamed xp sp2. When i test it in vmware, it does not put in the settings that are in the answer file. I want to choose my partition and which file system i wanna use, but I want the GUI install to be totally unattended, but the prob is when i get to the gui part, it does not do what it should from the winnt.sif file. I have posted my winnt.sif file below of course removing certain info, can anyone please tell me what I have done wrong. Please post a copy of my winnt.sif file with any alterations i need to make, so that when I run vmware, I can choose the file system and partition but have the rest of it unattended.

;SetupMgrTag

[Data]

AutoPartition=0

MsDosInitiated=0

UnattendedInstall=Yes

AutomaticUpdates=yes

[unattended]

UnattendMode=GuiAttended

OemPreinstall=Yes

TargetPath=\WINDOWS

UnattendSwitch=yes

WaitForReboot=No

[GuiUnattended]

AdminPassword=Removed Password Encryption Info

EncryptedAdminPassword=Yes

OEMSkipRegional=1

TimeZone=25

OemSkipWelcome=1

[Display]

Xresolution=1024

Yresolution=768

[userData]

ProductKey=Removed Key For Now

FullName=Something

OrgName=None

ComputerName=Something

[TapiLocation]

CountryCode=107

Dialing=Tone

AreaCode=306

[RegionalSettings]

LanguageGroup=13,17,3,2,5,16,4,12,15,7,8,10,11,9,6,14,1

Language=00001009

[shell]

CustomDefaultThemeFile="%WinDir%\Resources\Themes\CrystalBlue.theme"

DefaultStartPanelOff=No

[identification]

JoinWorkgroup=WORKGROUP

[Networking]

InstallDefaultComponents=Yes

Link to comment
Share on other sites


[unattended]

UnattendMode=GuiAttended

GuiAttended

Specifies that the GUI-mode section of Setup is attended. When specified, the end user is required to answer all questions in the GUI-mode portion of Setup before Setup finishes.

Use UnattendMode = GuiAttended in preinstallation scenarios when you want to automate only text-mode Setup.

That should be:

UnattendMode=FullUnattended

Link to comment
Share on other sites

If you wanna to choise your partition ,please put

AutoPartition=1

second put your winnt.sif into your i386 directory and check for old one. If you have old winnt.sif you should remove it.

Link to comment
Share on other sites

AutoPartition

Value: 1

Installs Windows to the first available partition that has adequate space for a Windows installation and does not already contain an installed version of Windows.

Just leave it like it is: AutoPartition=0

Another thing to check, make sure winnt.sif isn't named winnt.sif.txt. It's a common problem when saving from text editors.

Link to comment
Share on other sites

I just made some changes. I just realized with that last post that that may be my problem, could you recommend how I can properly make sure it is named winnt.sif.txt Here are the changes

;SetupMgrTag

[Data]

AutoPartition=0

MsDosInitiated="0"

UnattendedInstall="Yes"

[unattended]

UnattendMode=FullUnattended

OemSkipEula=Yes

OemPreinstall=Yes

OemSkipEula=Yes

WaitForReboot="No"

KeyboardLayout="Canadian English"

TargetPath=\WINDOWS

[GuiUnattended]

AdminPassword=Removed for security purposes

EncryptedAdminPassword=Yes

OEMSkipRegional=1

TimeZone=25

OemSkipWelcome=1

[userData]

ProductKey=Removed for security purposes

FullName="Removed For Security Purposes"

OrgName="None"

ComputerName=ASUKA

[Display]

BitsPerPel=32

Xresolution=1024

YResolution=768

Vrefresh=60

[TapiLocation]

CountryCode=107

Dialing=Tone

AreaCode=306

[RegionalSettings]

LanguageGroup=13,17,3,2,5,16,4,12,15,7,8,10,11,9,6,14,1

Language=00001009

[identification]

JoinWorkgroup=WORKGROUP

[Networking]

InstallDefaultComponents=Yes

[shell]

CustomDefaultThemeFile = "%WinDir%\Resources\Themes\CrystalBlue.theme"

DefaultStartPanelOff = No

Link to comment
Share on other sites

You want to make sure it does *NOT* have the .txt at the end.

easiest way is to open it in notepad.

go to FILE>SAVE AS

type in winnt.sif

in the box below, make sure it says "All files" not "text document".

this will ensure saving in the proper format.

Link to comment
Share on other sites

Go to Folder Options, on the View tab make sure that 'Hide extensions for known file types' is not checked. You will then be able to see if it has then .txt extension.

If you want to keep known file type extensions hidden, just let the mouse hover over your winnt.sif file, if the tool tip identifies it as a SIF file, then it's okay.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...