Jump to content

problem installing xp from pe cd


Recommended Posts

gday all.

ok, im trying to get bartPE to install xp, so i run winnt32.exe /syspart:c: /tempdrive:c: /unattend:<location>winnt.sif and that works fine. im not using cmd.exe as my shell so i have to manually reboot when winnt32.exe finfishes. that fine (would be nice if i didnt have to but meh....)

so here is my problem. comp reboots and txtsetup starts... works fine untill i says "checking drive c" it then says "Setup was unable to verify drive c:, your comp may not have enough memory to examine the drives, or your windows xp cd may contain some corrupted file. to continue press enter" so i do..

then it says "Setup cannot access the cd containging the windows xp installation files... press enter to retry or f3 to exit"

ok. to the windows cd is located under the cd root in a folder "winxp cd" and under that is the i386 folder.

now is the problem with the location of the files? how are they supposed to be...

my disk currently looks like this

- i386 (bartpe folder)
- programs (also bartpe folder)
- winxp pro (copied the entire xpcd here)
  -  i386


Link to comment
Share on other sites


I think that when you launch setup form an existing OS, Windows expects to find the installation files under \i386, that's your i386 folder must be under the root of the CD, (this unlike when started from bootable CD).

So, I think the best solution is to change BartPE folder to any other four letters (of course, after hexediting the bootsector and setupldr.bin to refere to the new folder) and reserve the i386 folder to Windows installation files.


Link to comment
Share on other sites

i was hoping this wasnt the case :D

i dont want to hex edit the boot files so iv done a text repace in txtsetup.sif and changed all \i386 to \winxp\i386 and hopefully that will work.. or is there other setup files that need to be fixed?

if this doesnt work looks like i can just use the /s: switch forgot about that 1 :)

EDIT: looks like editing the txtsetup.sif file worked... i less parameter to run winnt32.exe with :D:rolleyes:

EDIT2: wtf is with the emotican limit?

Link to comment
Share on other sites


I thought you already made the required changes to txtsetup.sif.

Anyway, try to complete the setup, because as I remember, it didn't work for me after the computer restarted and setup kept to ask me for missing files.

I think this was an upgrade to Win98, don't remember well.


Link to comment
Share on other sites

yup guimode setup thingy didnt work... ok havta use the /s switch

s if for sources...

I near a good script + command line :

/sc:\winxp\i386 (in your case)

my still problem is that $oem$ isn't copied for now... nevermind where it is store (in or side of i386)

there is also an oemfilespath unattend param that I'm testing at work (result to test in few hours; I'm not at work now :) )

testing all in a vmware and a modified b.pecd with a linux samba share...

---see later

Link to comment
Share on other sites

ok, i made the wrong change to txtsetup.sif so i changed it back and did the correct change (from the multiboot cd guide)

anyway it didnt work... /s didnt work either but that could be becuase te txtsetup.sif was buggered up, so im trying it with /makelocalsource now... (yes im stuck in winpe coz i formatted expecting it to work but it isnt :'(

EDIT: w00t im back in windows :rolleyes: /makelocalsource worked was a bloody quick install also... im pretty sure it went from 37min -24 min instantly and then that last bit too about 5 min :)

Edited by jdgordon
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...