Jump to content

SpyBot 1.3


Sield
 Share

Recommended Posts

Hi everybody !

Spybot 1.3 is up, and there is the switches i use for a perfect silent install :

echo Installation de Spybot Search & Destroy

start /wait %systemdrive%\Spybot_13.exe /VERYSILENT /NOCANCEL /TASKBARHIDE /AUTOCLOSE

echo.

exit

It's run fine for me, and i hope this will help U.

Link to comment
Share on other sites


this is what i use, it gets it installed, installs the sdhelper bho, teatimer at startup and copies my ini files across so that all the settings are right. hope this is of some use:

In My RunOnceEx

REG ADD %KEY%\150 /VE /D "SpyBot: Search and Destroy 1.3" /f
REG ADD %KEY%\150 /V 1 /D "%systemdrive%\install\Applications\SpyBot12\SpyBot13.exe /verysilent /components=\"main\"" /f
REG ADD %KEY%\150 /V 2 /D "%systemdrive%\install\Applications\SpyBot12\Config.cmd" /f
REG ADD %KEY%\150 /V 3 /D "REGEDIT /S %systemdrive%\install\Applications\SpyBot12\Settings.reg" /f

In My Config.cmd

@echo off
cmdow @ /HID

XCOPY "%systemdrive%\Install\Applications\SpyBot13\configuration.ini" "%allusersprofile%\Application Data\Spybot - Search & Destroy\" /C /Y
XCOPY "%systemdrive%\Install\Applications\SpyBot13\Default configuration.ini" "%programfiles%\Spybot - Search & Destroy\" /C /Y

EXIT

In My Settings.reg

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{53707962-6F74-2D53-2644-206D7942484F}]
@=""

[HKEY_CLASSES_ROOT\CLSID\{53707962-6F74-2D53-2644-206D7942484F}\InprocServer32]
@="C:\\PROGRA~1\\SPYBOT~1\\SDHelper.dll"
"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{53707962-6F74-2D53-2644-206D7942484F}]
@=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{53707962-6F74-2D53-2644-206D7942484F}\InprocServer32]
@="C:\\PROGRA~1\\SPYBOT~1\\SDHelper.dll"
"ThreadingModel"="Apartment"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{53707962-6F74-2D53-2644-206D7942484F}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"SpybotSD TeaTimer"="C:\\Program Files\\Spybot - Search & Destroy\\TeaTimer.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\PepiMK Software\SpybotSnD]
"TeaTimerHide"=dword:00000001
"Language"="English"
"BotFilter"=dword:ffffffff
"CheckDownloadSubs"=dword:00000001
"SDHelperMode"=dword:00000000
"WizardRun"=dword:00000001
"RecoveryAged"=dword:00000001
"WaitStartDelay"=dword:00000001

In My Directory

Config.cmd
Configuration.ini
Default configuration.ini
Settings.reg
SpyBot13.exe

In My 2 INI Files (both the same)

[Installation]
DesktopIcon=NoIcon
QuickLaunch=NoIcon

[Installation\StartmenuItem]
Easy=0
Advanced=0

[Main]
EasyMode=0
Legals=1
AutoSave=1
CreateBackups=1
CreateTrackBackups=1
CreateSystemBackups=1
CreateSystemRestorePointSpyware=1
CreateSystemRestorePointInternals=1
IgnoreIncludeFileError=1
Confirmation=1
Compability=1
Priority=Normal
RecoveryAged=1

[Main\AlertSounds]
AlertSpyFound=0
AlertNothingFound=0

[Automation\ProgramStart]
AutoCheck=0
AutoFix=0
RerunAfterFix=0
AutoImmunize=1
DontAsk=0
WaitStart=0
WaitPrograms=0
WaitMore=0

[Automation]
SystemStart=NoAutomation

[Automation\SystemStart]
AutoCheck=0
AutoFix=0
WaitStart=0
WaitPrograms=0
WaitMore=0
AutoClose=0

[Automation\WebUpdate]
AutoCheck=0
AutoDownload=0
RemindUpdate=1
CheckBetas=0
CheckAllLanguages=0
CheckSkins=0
CheckSignatures=0
UseProxy=0

[Logfile]
WriteCheckLog=1
WriteFixLog=1
IncludeLogDetails=1
OverwriteLog=0

[Look]
BlindUser=0
DisplayHeader=1
InfoPanelHighlight=0

[BugReport]
UseDefaultMailer=1
IncludeSysInfo=1
IncludeResults=1
IncludeActiveX=1
IncludeBHO=1
IncludeBrowserPages=1
IncludeProcessList=1
IncludeStartup=1
IncludeWinsockLSPs=1
IncludeClipboardText=0
IncludeClipboardImage=0
IncludeSpyFiles=0
CarbonCopy=1

[Expert]
ShredTracks=1
ShredRecovery=1
ShowResultsButtons=0
ShowRecoveryButtons=0

[Expert\Viewer]
HelperUseFiles=0
HelperUseFolders=0
HelperUseRegistry=0

[Filesets]
Spybot - Search & Destroy=1
Cookies.sbi=1
Dialer.sbi=1
Hijackers.sbi=1
Keyloggers.sbi=1
LSP.sbi=1
Malware.sbi=1
Revision.sbi=1
Security.sbi=1
Spybots.sbi=1
Trojans.sbi=1
Usage Tracking=0
Tracks.uti=0

[Durations]
Spybot - Search & Destroy=0
Cookies.sbi=0
Dialer.sbi=0
Hijackers.sbi=0
Keyloggers.sbi=0
LSP.sbi=0
Malware.sbi=0
Revision.sbi=0
Security.sbi=0
Spybots.sbi=0
Trojans.sbi=0
Usage Tracking=0
Tracks.uti=0

[Windows]
SplitterResults.Maximized=1
SplitterResults.RestorePos=232
SplitterStartup.Maximized=1
SplitterStartup.RestorePos=232
ListResults.Column0.Width=507
ListResults.Column1.Width=100
ListRecovery.Column0.Width=210
ListRecovery.Column1.Width=100
ListLanguages.Column0.Width=210
ListLanguages.Column1.Width=100
ListStartup.Column0.Width=210
ListStartup.Column1.Width=100

[Tools.Visibility]
aToolsActiveX=1
aToolsBHOs=1
aToolsBrowserPages=1
aToolsHosts=1
aToolsProcessList=1

this way nothing needs else needs to be tweaked. just need to run program once i think, to perform the immunize, which i suppose you could add a registry entry under normal runonce

Link to comment
Share on other sites

This was already posted under Switches..but regardless, the best way I've found was to use the start.cmd file, and use the code

ECHO.
ECHO Installing Spybot 1.3
ECHO Please wait...
start /wait %systemdrive%\install\Applications\Spybot\spybot13.exe /VERYSILENT /dir="%systemdrive%\program files\spybot" /group="SpyBot" /components=" , , "
ECHO.
ECHO Updating Spybot 1.3
ECHO Please wait...
start /wait "%systemdrive%\Program Files\Spybot\spybotsd.exe" /taskbarhide /autoupdate /autoimmunize /autoclose

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...