Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Can't open device manager


darxide
 Share

Recommended Posts

Ok, I can, but only if I Win+R and type devmgmt.msc (or from a command prompt). But that's the only way that I can get it to open. The traditional keyboard shortcut of Win+Break does nothing. Right clicking the Start icon and picking Device Manager does nothing. Typing "Device Manager" into the Start menu search and clicking the result does nothing. Nothing at all. Zip. Nada. No sign that it tried and failed. No signs that it tried anything. Going into settings, I can't seem to even find "Device Manager" unless I type it into the search. I don't know where it's buried under the dumbed down Windows 10 settings vs previous versions of Window's Control Panel.

All other options in the right click Start menu  works perfectly fine. Only Device Manager fails.

Bottom line is that if I can get the Win+Break shortcut to work again then I'll be perfectly content with that. Googling this gives half a dozen different ways to "fix" this, all of which are either irrelevant or didn't work. Any clue how I can fix this?

~Thanks.

 

Edit: Another thing, I don't know if this is relevant or not but if I open up Control Panel instead of "Settings" the window that comes up is blank.

Edited by darxide
Link to comment
Share on other sites


sorry, i don't have a solution for the keyboard shortcut related issues. as for the location of device manager link, for version 20H2 of windows 10, it should be in the settings - system - "about" page, listed somewhere on the right under "Related settings". though the problems you explained such as control panel opening up being blank could maybe due to a corrupt operating system. which version of windows 10 are you using? the version is also listed in settings - system - "about" page, under windows specifications.  

Link to comment
Share on other sites

  • 2 weeks later...

I've found the spot in the System->About that you mentioned, but clicking on System Info has the same effect as everything else. That is, nothing happens at all. So far, the only way I've found to open Device Manager is via devmgmt.msc.

 

I am still on version 1903 currently.

 

EDIT: I also ran another SFC scan just to be sure:

Quote

Windows Resource Protection did not find any integrity violations.

 

Edited by darxide
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...