Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
phaolo

Some problems after the 2018 patches

Recommended Posts

Posted (edited)

Hello, I've recently installed 1-year-worth of Win7 Security-Only patches (due to the new Spectre exploits, mostly).
It all went well, except for these things:

1- various programs set to run at Window’s start in the registry.. don’t seem to do it anymore.

I’ve already tried to reset the startup option inside their settings, but nothing changed.
Their keys are correctly present in the registry inside the \Run sections, as before the update.

I’ve also noticed this new error in Eventviewer (related?):
EventID 1530

1 user registry handles leaked from \Registry\User\[code here]: Process 936 (\Device\HarddiskVolume5\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\[code here]

Error 1530 can happen at shutdown and it's usually a semi-harmless event ("by design"), but.. it's weird that I'm getting it at logon now.

2- some programs’ windows positions and sizes aren’t saved when I close and reopen them.
I wonder if this is also caused by the event mentioned above.

3- I noticed another minor but annoying change about symbolic links.
When traversing folders in the Navigation pane, now Windows Explorer always jumps to their original path (like a normal link), instead of remaining in its current tree structure.

--

Has anyone experienced these issues too? Or have a clue on how to fix these?
I already tried running sfc /scannow, but it didn’t find any integrity violation.

Edited by phaolo

Share this post


Link to post
Share on other sites

Posted (edited)

Well, problems 1 and 2 seem solved:
1- I tried Safe Mode and also edited some registry \Run entries missing quotations. That fixed it, it seems.
2- I tried temporally changing resolution and updating the graphic drivers.. no change. Then I just used an option to tile the windows automatically and.. they somehow unfroze. XD

Problem 3 still persists, instead.
I also noticed that junctions kept their previous behaviour.
Why MS even bothered to modify it for simlinks?


If someone has Windows 7 (up to date): can you please test the Navigation Pane issue?

If you can see hidden folders, the easiest way to do it is here:
"C:\Users\All Users\" is a symlink. Nav Pane jumps to "C:\ProgramData" now.
"C:\Users\All Users\Documents" is a junction. Nav Pane stays in the same tree.

Edited by phaolo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...