Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Will Dr. Watson tell you why a DLL load failed?

Recommended Posts

I'm at the point where opera.dll 12.18 - IP.41 says no patches needed, even if I select Walk Dependencies. But Opera throws the message
"Autoupdate failed init: -2" and waits for me to hit OK, then it goes away. Which I guess has been seen before:

This is with RASAPI32.dll from win-98. About the only thing left to try is the win-me version. My previous attempt with the win-2k version (5.00.2195.6920) of rasapi32 gave issues (IP.41) with rasman.dll, which I have in windows/system (again, win-2k version). I believe the issues with rasman.dll are because of ntdll.dll:


Then again, I have no idea if fixing those, and using win-2k versions of rasapi32 and rasman.dll will get opera 12.18 working.

What is this "Autoupdate" thing that Opera is trying to do? Any way to stop it?


Share this post

Link to post
Share on other sites

Opera.exe (v 12.02 and v 12.18) work fine with Opera.dll (v 12.02).  Both versions of Opera.exe give the Autoupdate error when used with Opera.dll v 12.18.  (at least that's where I am right now).  On the Opera discussion forum, regarding the autoupdate error:

See if it thinks it has downloaded an update - if it has, delete it. On Windows 10 machine Opera 12.18 starts fine, but when asked to check for updates it said "Update check failed".

Another post said to open up operaprefs.ini (in the profile folder) and look for "Level Of Update Automation=" and "Auto Update State=" and set them both to =0 if they're not already. If that doesn't solve the problem then try removing / renaming operaprefs.old and try restarting.

I have operaprefs.ini in c:\windows\application data\opera and both of the above settings are indeed set to 0.  

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...