Jump to content

win98se & pci-e


Recommended Posts

Hi all - first post on the forum. Recently I've been attempting to run W98se on older pci-e based motherboards with the objective of getting a 7800gtx/256mb running - ideally a 7900gtx - to play late W98 era/post Glide games that benefit from extra ram/gpu but that don't always play nice under XP/W7, even with fixes and patches - games like USAF.

For W98se I install the fixes/performance tweaks [only] from Unofficial SP 2.1 and SP 3 final, add nusb33e, and the modded nV 8269 drivers. I'm sticking with 512mb system ram until I can get gpu issues sorted.

So far I've tested 2 VIA/socket 775 based boards: MSI P4M900M2-L and a Biostar P4M890-M7-TE - both have W98se chipset drivers so I was hopeful.

W98se runs, but no matter what I've tried I run up against a wall with pci-e. The 7800gtx gets recognized [needed to install drivers via Device Manager], but will only run in VGA mode or Windows will hang on reboot after the splash screen.

On deck is salvaged HP dc7100 workstation motherboard [#3509929-001]. It has an Intel 915G/P/GV chipset, which from the MSFN W9x hardware sticky seems to be okay, and I downloaded W98se drivers from the HP site.

Anyone have experience with this board? I'll be assembling/testing over the weekend and will post results.

And more generally what tips do people have to wrangle pci-e slot setups into working under W98se - they seem to be plagued with trouble but i read scattered reports of success...

Edited by tincup2
Link to comment
Share on other sites

Update: No luck with the HP 350929-001 board either, though it was far less 'balky' and showed much initial promise. Still, it locked up at the W98 splash screen, or at a black screen/flashing cursor after critical re-boots to fully initialize the pci-e card. Like the others it boots to Safe Mode, seems okay, then fails.

I feel like I may be missing a critical fix, or a special step in the operation.

Is there a proven W98se motherboard/pci-e 256mb gpu combo out there?

Link to comment
Share on other sites

Are you sure your card is listed in the inf of the driver? The copy of NV 82.69 that I have lists no

7800 cards at all. Windows may install drivers but refuse to load them on reboot in the product id

is missing from the inf. You can try manually adding the id if it's not there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...