Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Win2K Server reinstall, Windows Update issues

Recommended Posts

Hello. First post.

I am currently trying to install a fresh copy of Windows 2000 Server and having issues with Windows Update. I've been using the instructions from but wonder if any of it (particularly step 7) is specific to 2000 Professional? (I am also unclear what step 7 accomplishes that a straight install of Windows Update Agent doesn't.) Everything went fine until section C. Windows Update ran and suggested the BITS/WinHTTP and Installer updates as noted. They downloaded but then repeatedly failed to install. For each update, Event Viewer said

"Installation Failure

Error Code: 0x80242000

Try to install the update again, or request help from one of the following resources."

which translates to "the caller requested a remote object, but no remote process is available".

So I downloaded the two updates manually, and they installed normally. Upon re-running Windows Update, I now get the error

"Files required to use Windows Update are no longer registered or installed on your computer. To continue:

_ Register or reinstall the files for me now (Recommended)

_ Let me read about more steps that might be required to solve the problem"

and WindowsUpdate.log says

1424 58c COMAPI -------------

1424 58c COMAPI -- START -- COMAPI: Search [ClientId = WindowsUpdate]

1424 58c COMAPI ---------

1424 58c COMAPI FATAL: Unable to connect to the service (hr=80080005)

1424 58c COMAPI WARNING: Unable to establish connection to the service. (hr=80080005)

1424 58c COMAPI - WARNING: Exit code = 0x80080005

1424 58c COMAPI ---------

1424 58c COMAPI -- END -- COMAPI: Search [ClientId = <NULL>]

1424 58c COMAPI -------------

1424 58c COMAPI FATAL: Unable to initiate asynchronous search, hr=80080005

IMHO it would be more helpful if the log indicated exactly which "Service" was unavailable. Since then I've tried the "Register or reinstall the files for me now" option. Early attempts seemed to make the HTTPS connection pause indefinitely, but lately it has been doing something...that still doesn't fix the problem. I tried installing Microsoft Update, but that generates similar COMAPI errors as above. I have since been re-registering DLL's used by Windows Update and the Cryptography API, and renaming/deleting/flushing various things in WINNT\SoftwareDistribution, but so far nothing has helped.

Any suggestions? Should I stop overthinking this and just reinstall from scratch, perhaps skipping the custom Windows Update Agent installer? I don't usually troubleshoot Windows on such a low level and it's such a Rube Goldberg machine... :(

Edited by thetao

Share this post

Link to post
Share on other sites

Funnily enough, I just fixed it myself. I went through the custom WUA.EXE installer, comparing the file sizes to what was actually installed, and was surprised that roughly half the files were the wrong versions. So I copied these .dll's, .exe's, and .mui's to their proper locations. Winhttp.dll was a little tricky. At that point, Windows Update skipped past the error, but cited that BITS/Winhttp wasn't installed. I tried installing it through Windows Update, and again it failed. So I reinstalled it manually. After a reboot, Windows Update is now working normally, and I was able to download and install a small Security Update.

So problem solved. Thanks everybody, and thanks ppgrainbow! :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.