Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Vista Black Screen White Mouse Cursor KSOD (blacK Screen Of Death)

Recommended Posts

I'm working on a friend's Toshiba Satellite (AMD X2, ATI Radeon running Windows Vista Home Premium) that's got a very unusual problem. While the system turns on and boots, Windows does not load in the traditional sense. When the GUI begins to load, the background is completely black and all I have is a mouse cursor.

I'm aware that this symptom manifests itself in a few distinct ways:

  • When booting normally the system is responsive to CTRL+ALT+DEL or pressing the SHIFT key 5 times allowing one to launch Explorer & 'get by'
  • When the system isn't responsive when booting normally, the system can boot into Safe Mode & function normally, allowing one to try a barrage of techcniques.
  • When booting normally or into Safe Mode, the system is not responsive to anything.

I'm in the latter category: When booting in Safemode, either regular Safemode, Safemode with Networking or Safemode with Command Prompt, the mouse cursor can be seen, it moves around but that's it - buttons don't do anything, no amount of key strokes does anything.

I Googled 'Vista Black Screen', or something along those lines, and got a significant number of results. I jumped on the first result, where a wall of text defeated me:


I tried everything that was on there, and more, but nothing worked:

  • renamed event logs folder & created a new empty folder
  • system is non-responsive to ctrl+alt+del or ctrl+shift+esc
  • booted into safemode (regular, with networking & command prompt) - system is non-responsive like above
  • tried 'Startup Repair' (says nothing is wrong)
  • tried System Restore (no restore points!)
  • tried 'Last known good state' (no change)
  • confirmed 'Shell' registry key is just explorer.exe (and not something else)
  • confirmed RpcSs is set to NT Authority
  • press shift key 5 times; I hear the sound but no display window appears
  • leaving the system at the screen for several minutes does nothing (system actually goes to sleep/hibernates but comes back to the same place; keeping it awake for even 45-60ish minutes does nothing)
  • ran chkdsk (saw a few 'cleaning up X unused index entries from index $SII/$SDH of file 9' messages, one 'cleaning up x unused security descriptors', one 'fixing mirror copy of the security descriptors data stream' and it finished with 'found no problems'. Interestingly enough, when I slave the drive, Windows says there are problems so I check it again.
  • ran icacls and gave everyone full access to c:\*
  • cloned the drive problem still exists
  • installing from scratch is fine

I've already backed up what needs to be backed up, but there are some particulars that need to be exported from applications for use on another machine. This is why we're trying to get into Windows, just once :), to launch the apps, export whatever, then ditch the machine since its already been replaced.

The owner of the system is very non-technical so its difficult to say what happened. She doesn't believe any software was added or removed from the machine, but also couldn't say whether or not it was receving & Installing Windows Updates automagically. Even so, if there was some sort of update that foobar'd this machine, there's no way for me to uninstall it now...or is there?

About Startup Repair: I tried it a few times on both the original hard drive and the cloned hard drive with no change. Each time it claims it doesn't detect anything wrong, and/or that it cannot be fixed, but, when expanding the details section, you can see that something did fail at some point:

Root cause found:


Unspecified changes to system configuration might have caused the problem.

Repair action: System files integrity check and repair

Result: Failed. Error code = 0xa

I tried 'sfc /scannow /offbootdir=DRIVE /offwindir=DRIVE:\Windows' but it says 'There is a system repair pending which requires a reboot to complete. Restart Windows and run sfc again.' every time. I rebooted a few times and it reported the same thing every time. The 'solution' for that was to remove the 'pending.xml' file in '%windir%\winsxs\' but I don't know what possible rammifications that may cause. In any event, it did its thing then reported that 'Windows Resource Protection found corrupt files but was unable to fix some of them'. Using this as my guide, http://support.microsoft.com/kb/928228, I discovered there weren't any "[sR]" entries in the CBS.log, but there were a few "err"ors and "fail"ed entries. For brevity's sake I'm not going to paste the log here but you can find the log here: http://www.juli.us/support/forums/technet_VistaKSOD_CBS.txt I'm still combing through it but its hard to identify what's of concern vs. an acceptable, non-threatening warning/error. Is there another option for sfc to forcibly repair any/all corrupt files with good files from the CD?

I also tried `bootrec /rebuildbcd` twice but that didn't work either. I remember it distinctly because it scanned for Windows installations, said it successfully scanned Windows installations, reported 0 identified Windows instllations then finished saying 'the operation completed successfully.' Seems a bit unusual to me. I ran ScanOS after that which also reported 0 installations and FixMBr, and FixBoot don't do anything to correct the problem either.

My coworker believes/is convinced this is a video driver issue. when booting into safe mode I see a few references to ATI drivers, like atipci.sys, being loaded. Based on that and what we've seen on some other forums we think that may be a cause/source of the problem. Who knows for sure. So we're going to see if we can fix it from that angle. Is there a basic/vga-only boot option for Vista that will not try to load any advanced video drivers? Is there an option to selectively choose which drivers Vista loads when booting? (interactive boot)

Oh how I long for the 'Repair Windows' feature on Windows XP. *sigh* Why oh why is that no longer an option?

I've reached the end of my rope and am looking for any insight into this.

Thanks again - I look forward to hearing more suggestions from anyone/everyone on this.

Your assistance is very much appreciated as always.


Edited by Phylum

Share this post

Link to post
Share on other sites

To backup the data, you have two choices:

- boot from a CD/usb drive and backup the files to another drive. Depending on what you know, you can try a live linuxCD/usb drive with ntfs support or a winPE based CD/usb drive. That also will help knowing what's wrong.

- remove the hard drive from the netbook and connect it in an usb enclosure on another computer. This is the safest way to backup as the first method could not work if there is an hardware problem on the notebook.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.