Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Odin

MBSA for Win2000, wsusscn2.cab not compatible :(

Recommended Posts

Hello, I am trying to use Microsoft Baseline Security Analyzer Windows 2000 Server, to check a (new) installation has all the latest updates.

However it has been a few months/years since I last did this and while I have installed all the updates I think I need from my repository, I'd like to be able to cross-check I have as many patches as possible applied.

I installed MBSA 2.1 for it to complain "Computer has an older version of the client and security database demands a newer version. Current version is and minimum required version is 5.8.0.2678". I know MBSA 2.1 used to work with Win2000.

So I isntalled MBSA 2.2. To get the same error.

Obviously Win2000 is well past support from microsoft, so is the problem that microsoft have withdrawn the data or not kept things compatible ?

Is it possible someone has a wsusscn2.cab file which is compatible with MBSA which is in effect the most up-to-date and working version of wsusscn2.cab for the Windows2000 series ? I believe I can manually install this file and have MBSA work with the offline copy (i.e. don't connect to microsoft.com to check for an updated cab and overwrite it).

Alternatively what other tooling is available that understands the operating system patching/update system which can do a similar job ?

Thanks

Edited by Odin

Share this post


Link to post
Share on other sites

I installed MBSA 2.1 for it to complain "Computer has an older version of the client and security database demands a newer version. Current version is and minimum required version is 5.8.0.2678". I know MBSA 2.1 used to work with Win2000.

This may not be clear from the error message, but what it sounds like it is complaining about is *NOT* MBSA, but Windows Update Agent. You will need to update this. You can either do that by going to the Windows Update website (it should not load without prompting you to upgrade this), or by downloading the offline update. The current version of the piece it sounds like its complaining about is 7.4.7600.226.

http://support.microsoft.com/kb/949104

Hope this gets it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...