Jump to content

0 for 6 on attempted install


 Share

Recommended Posts

OK, it's time to ask for some feedback:

I've been attempting to manually build a working install CD to do a clean install of XP SP3 on my HP laptop including all of my HP drivers. I'm 0 for 6 so far. I'm going to describe 2 of my attempts and then i'll describe my current configuration.

Attempt #4:

I think I finally had the info on my SATA driver right and I believe my Txtsetup.sif was correct. (info below) But due to a quirk in Nero 6 it didn't pick up that I had renamed the $OEM$\Driver\SATA & chipset folders so that my Winnt.sif pointed to nonexistent folders and the Intel chipset drivers never got installed. The install finished but on bootup it went to the "F8" screen. I tried Safe Mode but it wouldn't boot. Looking through the install logs on the C: drive it appears that most or all of my drivers got installed except for the chipset.

Attempts #5 & #6:

I *believe* I have everything right but it finishes the textmode, reboots and stops at: "Press any key...." Never gets to the GUImode. If I were to pop out the CD at this point it just shows a blinking cursor - not the "can't find ntlr" error I would expect. There are currently 688mb of files on the C: drive copied there during the textmode including ntlr, ntdetect.com and boot.ini. So does this say that my SATA driver is not getting loaded for GUImode? Or what?

My install source is a M$DN copy of XP SP3 Retail (checked MD5). I've added my 4 OEMBIOS file and updated the setupp.ini to do a SLP OEM install. No addons or updates integrated.

Here's my folder setup:

-- i386

-- etc folders

-- $OEM$

-- .....$1

-- ..........Drivers

-- ................00_SATA

-- ................01_C_set (Intel chipset, USB, PCI)

-- .................etc folders (10 total)

This is added to the end of the Txtsetup.sif (before the EOF marker):

[SourceDisksFiles]
iaStor.sys = 1,,,,,,3_,4,1

[HardwareIdsDatabase]
PCI\VEN_8086&DEV_27C5&CC_0106 = "iaStor"

[SCSI.load]
iaStor = iaStor.sys,4

[scsi]
iaStor = "Intel® 82801GBM SATA AHCI Controller (Mobile ICH7M)"

(and, no, it didn't get saved as "Txtsetup.sif.txt")

This is the pointer in the Winnt.sif file to the drivers:

OemPnPDriversPath = "Drivers\00_SATA;Drivers\01_C_set;Drivers\graphics;Drivers\T_pad;Drivers\audio;Drivers\NIC;Drivers\wireless;Drivers\PCI_card;Drivers\SD_card;Drivers\modem;Drivers\HP_MDP;Drivers\infrared"

I added a compressed copy of my SATA driver - iastor.sy_ - to the i386 folder.

I've attached my Winnt.sif file.

I'm out of ideas. Appreciate any tips I can get here.

laffin_boy

Winnt.sif

Edited by laffinboy
Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...