Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
cure

Patched system suddenly incompatible with WordPerfect

Recommended Posts

I am having trouble with WordPerfect on my newly patched 98SE install. I have the 98SE-ME file replacement, the Kernel Project, and Revolution 9 installed and I have the whole thing updated with the Autopatcher.

Now Wordperfect X3 (13) and Wordperfect 12 both install but have a curious and frustrating set of problems connected to their writing tools.

Grammatik has a small bug. The spacing is wrong in the last two lines, where a new sentence is proposed and where the problem with the existing sentence is described: a large space is left in the middle of the line with any text not fitting to the left of it being pushed to the extreme right and sometime out of the visible viewing area.

Far worse, upon initiating the spell checker I get the following response: "There is an error in the Speller Checker's Window Registry information". If one keeps tappping OK one can begin to spellcheck. Much better is to switch to Grammatik, which works perfectly, or, better still, switch back from it to Spell Checker that then works correctly, or at least until one makes an edit in the document and one must hit Resume, requiring one to repeat the switch into and out of Grammatik to again regain proper functionality.

Spell-as-you-go and Grammar-as-you-go both fail to start, reporting: "Unable to initialise. Make sure user word list is available."

Perhaps in a related vane, the program systematically erases the following registry key which is present on another 98SE system that is also patched but not with all the latest stuff and whereupon WordPerfect works perfectly:

"[HKEY_CURRENT_USER\Software\Corel\WritingTools\13\User Word Lists\UK\Word List 0]

"Enabled"=hex:01,00,00,00

"Name"="C:\\Program Files\\Common Files\\Corel\\Shared\\Writing Tools\\WT13UK.uwl"

Perhaps related, perhaps not, the backspace key sometimes fails in Word Perfect when playing around with the spell checker and Reveal Codes don't always work via key strokes, although they always work via the menu.

I also sometimes receive invalid page faults when exiting in WT13LI.DLL and WPWIN13.DLL caused by WPWIN13 and similarly in the Wordperfect 12 equivalents.

I have tried reinstalling, doing a repair install, deleting the registry keys responsible for writing tools, and the main Corel registry keys, before doing the reinstall.

I have largely compared the registry settings for WordPerfect from the other machine.

I have tried copying over the files from the other machine.

All to little effect.

BUT, I suspect that the new install is perhaps being recognised by the software as being a more recent OS than 98SE and in consequence a different and ultimately incompatible set of files are being installed. How might this be verified and addressed?

Other software, including Outlook XP, has installed and functions without a problem however.

I have tried various kernel settings including uninstalling it, but to no avail.

Can anyone suggest a lead?

Share this post


Link to post
Share on other sites

suspect that the new install is perhaps being recognised by the software as being a more recent OS than 98SE

...or being recognised as the out-of-the-disc w98SE while your platform has many new files installed. If the program thinks it's running under w98se, it won't expect to meet Kernelex, dll's from windows 2000 sp4, 1Gb of memory and stuffs like that.

Just my 2ct.

Edited by Fredledingue

Share this post


Link to post
Share on other sites

The Grammatik error appears with the activation of Clear Type and goes away with the Disactivation of Clear Type. As it is mostly cosemetic and can be worked around with a few key clicks, that is not to bad.

WP 13 installed immediately after the Autopatcher and prior to the Revolution Pack 9 (the kernel, etc.) works perfectly except the cosmetic error just discussed.

Edited by cure

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×