Jump to content

ftp access after ie8 install


mcginnf
 Share

Recommended Posts


220 g3u0041.houston.hp.com FTP server (hp.com version whp02s) ready.
USER anonymous
331 Guest login ok, send your complete e-mail address as password.
PASS IEUser@
230 Guest login ok, access restrictions apply.
CWD /pub/softpaq/sp41501-42000/sp41762.exe
550 /pub/softpaq/sp41501-42000/sp41762.exe: Not a directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (15,200,30,21,160,101)
LIST /pub/softpaq/sp41501-42000/sp41762.exe
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
TYPE I
200 Type set to I.
PASV
227 Entering Passive Mode (15,200,30,21,173,57)
SIZE /pub/softpaq/sp41501-42000/sp41762.exe
213 5119088
RETR /pub/softpaq/sp41501-42000/sp41762.exe
150 Opening BINARY mode data connection for /pub/softpaq/sp41501-42000/sp41762.exe (5119088 bytes).
426 Data connection: Connection reset by peer.

So we can see IE8 connecting, checking if it's a directory, checking if the file exists, switching to PASV mode, checking the file size and starting the download. So far so good. The problem is, you never actually receive any data. Then 30 seconds later, it terminates the data connection, gives you that 426 error (timed out), and terminates the command connection. Everything went over just fine, except that you didn't get the data itself.

Why do the data packets never make it? Could be a firewall/security app blocking it (although it is using PASV, so it shouldn't) or a number of things along those lines. In mattffrost's case it was the proxy settings, so I'd definitely check those first. You could also try with a real ftp client like filezilla (freeware).

Link to comment
Share on other sites

Since it's IE8, using fiddler to capture IE-specific traffic would be better (assuming you can use explorer.exe or a real FTP client to get the files properly from the same box, of course).

Link to comment
Share on other sites

Try turning on IE 8's Compatibility View by clicking the icon to the right of the address bar that looks like a broken piece of paper. This rolls back IE 8 to render pages as IE 7 would display them. This might allow you to access the FTP from hp.com.

Hope this fixes things,

- Jake

MSFT Internet Explorer Outreach Team

Link to comment
Share on other sites

Hello.

Using compatibility mode doesn't fix the ftp problem with IE8. It's really frustrating. I used to share my files with my brother by running ftp server software, and letting him view and download the files with his browser. Now that he's updated to IE8, he can't do that anymore. There should be a simple fix for this, but I can't think of one.

Link to comment
Share on other sites

Again, if it fails only in PASV, we're gonna need a network trace or a fiddler log from the client running IE8 to see what's happening. I do not have this problem on my IE8 box, so it's specific to this configuration it may seem.

Link to comment
Share on other sites

I've seen this problem a lot lately with a client of ours that uses FTP regularly and I usually end up resetting their Internet Explorer using the option under the Advanced Tab in Internet Options. The upgrade from earlier versions seems to fubar some of its functionality. A reset wipes the slate clean, kinda thing.

Before you do that though, try disabling passive (PASV) FTP mode in the Internet Options, as the big man of the Venn Diagram suggested.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...