Jump to content

VirtualBox Error with 64-bit VM's .. can anyone else confirm?


Recommended Posts

I'm wondering if the following could be a bug in the BIOS: When I suspend my box and then awaken it again, VBox doesn't run my 64-bit guest VM and gives this error:

VT-x/AMD-V hardware acceleration has been enabled, but is not operational.  Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.
Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

I rebooted and entered my BIOS. All my virtualization options are set to enable. If I totally power down my system, then boot, the problem is gone and the 64-bit VM works just fine. If I just reboot, the problem is not solved and the 64-bit VM does not work giving that error. This problem starts when the machine gets suspended and then awakened. Upon waking up, the symptoms I described above occur and they survive a reboot! Again, the only cure seems to be a power down then startup again (cold boot).

Can anyone else out there who has a 64-bit VM give this a try and report back?

1) Verify that the 64-bit VM works

2) Suspend your host machine then wake it back up

3) Try to run your 64-bit VM again and see if you get the same result I do

Link to comment
Share on other sites

What version of VirtualBox are you using?

What is the host Operating System?

What is the host CPU?

What is the host Motherboard?

In answer to your questions:

VB is the latest stable (2.2.0)

I can repeat this error using a host system of XP 64-bit, Arch Linux 64-bit and Ubuntu Intrepid-amd64. I have these three O/S's installed on the same physical machine, and it happens under all of them unfortunately.

The host CPU is an Intel Xeon X3360 and the host MB is a DFI LT P35-T2R running the latest BIOS revision.

Edited by graysky
Link to comment
Share on other sites

I figure it might be a problem with the guest additions so I tried to replicate the bug. I have different hardware, but I put Windows 7 (host) into Sleep while my Windows 7 (guest) is running. I then woke the host and the guest was running fine. I restarted the guest and still didn't get that error message.

Link to comment
Share on other sites

  • 3 weeks later...

I am having this problem now with VMware Workstation 6.5.2 :P

This host is VT-capable, but VT is not enabled.

This is usually due to a BIOS/firmware problem. Please:

(1) Verify the BIOS/firmware settings enable VT mode.

(2) Power-cycle the host, if the BIOS/firmware VT settings were changed at boot.

(3) Power-cycle the host, if you have not done so since installing VMware Workstation.

(4) Update host BIOS/firmware to the latest version.

You have configured this virtual machine to use a 64-bit guest operating system. However, this host is not capable of running 64-bit virtual machines or this virtual machine has 64-bit support disabled.

For more detailed information, see http://vmware.com/info?id=152

Shuttle SP35P2, Intel E8400, Windows 7 x64 RC, BIOS SP35S20E.

[EDIT] Fixed it, somehow it was disabled in the BIOS...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...