Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


RIS. Windows XP Pro w/SP2 and Intel Mass Storage Drivers issue

Recommended Posts

Hello all!!

I'm having issues getting our XP Pro w/SP2 RIS image to deploy on Dell's latest OptiPlex 760 desktop and the Latitude E Series laptops (E4200/4300/6400). In the past with the older Dell machines we'd set SATA mode in the BIOS to ATA mode and our image would deploy without any problems. Now with the release of the OptiPlex 760 and the E Series, if you change the SATA Operation mode from IRRT or AHCI to ATA, the eSATA port will be disabled and we can't have that.

Here's what I've done to date:

1. The following directories exist:




2. Modified the riprep.sif - changes in bold:


floppyless = "1"

msdosinitiated = "1"


OriTyp = "4"

LocalSourceOnCD = 1

DisableAdminAccountOnDomainJoin = 1


OsLoadOptions = "/noguiboot /fastdetect"

SetupSourceDevice ="\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"




OemPreinstall = Yes

OemPnpDriversPath = \Drivers\NIC;\Drivers\Storage

DriverSigningPolicy = Ignore

FileSystem = LeaveAlone

ExtendOEMPartition = 0

TargetPath = \WINDOWS

OemSkipEula = yes


LegacyNIC = 1


"Intel® ESB2 SATA AHCI Controller" = "OEM"

"Intel® ICH7R/DH SATA AHCI Controller" = "OEM"

"Intel® ICH7M/MDH SATA AHCI Controller" = "OEM"

"Intel® ICH8R/DH/DO SATA AHCI Controller" = "OEM"

"Intel® ICH8M-E/M SATA AHCI Controller" = "OEM"

"Intel® ICH9R/DO/DH SATA AHCI Controller" = "OEM"

"Intel® ICH9M-E/M SATA AHCI Controller" = "OEM"

"Intel® ICH10D/DO SATA AHCI Controller" = "OEM"

"Intel® ICH10R SATA AHCI Controller" = "OEM"

"Intel® ESB2 SATA RAID Controller" = "OEM"

"Intel® ICH7R/DH SATA RAID Controller" = "OEM"

"Intel® ICH7MDH SATA RAID Controller" = "OEM"

"Intel® ICH8R/ICH9R/ICH10R/DO SATA RAID Controller" = "OEM"

"Intel® ICH8M-E/ICH9M-E SATA RAID Controller" = "OEM"









ProductKey = "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

FullName = "Company Name"

OrgName = "Company Name"

ComputerName ="%MACHINENAME%"


OemSkipWelcome = 1

OemSkipRegional = 0

TimeZone = %TIMEZONE%

AdminPassword = "*"


BitsPerPel = 32

XResolution = 800

YResolution = 600

VRefresh = 60






DoOldStyleDomainJoin = Yes


Repartition = Yes

UseWholeDisk = Yes


Description ="Windows XP Pro SP2 w/Office 2003 SP1 v1.8 - OptiPlex/D&E Series/X1 Only"

Help ="Windows XP Pro SP2 w/Office 2003 SP1 v1.8 - OptiPlex/D&E Series/X1 Only"

LaunchFile ="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"

ImageType =SYSPREP

Version="5.1 (2600)"




3. Added the following to the TXTSETUP.sif:


PCI\VEN_8086&DEV_2681&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_27C1&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_27C5&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2821&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2829&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2922&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2929&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_3A02&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_3A22&CC_0106 = "iaStor"

PCI\VEN_8086&DEV_2682&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_27C3&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_27C6&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_2822&CC_0104 = "iaStor"

PCI\VEN_8086&DEV_282A&CC_0104 = "iaStor"


iaStor = "Intel® ESB2 SATA AHCI Controller"

iaStor = "Intel® ICH7R/DH SATA AHCI Controller"

iaStor = "Intel® ICH7M/MDH SATA AHCI Controller"

iaStor = "Intel® ICH8R/DH/DO SATA AHCI Controller"

iaStor = "Intel® ICH8M-E/M SATA AHCI Controller"

iaStor = "Intel® ICH9R/DO/DH SATA AHCI Controller"

iaStor = "Intel® ICH9M-E/M SATA AHCI Controller"

iaStor = "Intel® ICH10D/DO SATA AHCI Controller"

iaStor = "Intel® ICH10R SATA AHCI Controller"

iaStor = "Intel® ESB2 SATA RAID Controller"

iaStor = "Intel® ICH7R/DH SATA RAID Controller"

iaStor = "Intel® ICH7MDH SATA RAID Controller"

iaStor = "Intel® ICH8R/ICH9R/ICH10R/DO SATA RAID Controller"

iaStor = "Intel® ICH8M-E/ICH9M-E SATA RAID Controller"


iaStor = iaStor.sys,4

Now when I try to deploy our image, I receive the following error:

File txtsetup.oem caused an unexpected error (18) at line 1747 in d:\xpsprsm\ base\boot\setup\oemdisk.c.

I pressing any key several times the deployment is able to continue but then the image fails when trying to format the hard drive with the following error in the text mode portion of the setup:

Windows XP Professional Setup


The manufacturer provided file that Setup is trying

to use is corrupted or invalid:

Line 1 contains a syntax error.

Setup cannot continue. To quit Setup, press F3.

I've tried using Intel version 7.0 and 7.6 of their Storage Matrix Drivers along with Dell's drivers for the OptiPlex 760 and no luck.

Any help would be greatly appreciated!!



Share this post

Link to post
Share on other sites

I posted this is the Dell Forums earlier today... I am having the same problem with a different imaging method:

Optiplex 760 AHCI Imaging Problem

08 Dec 2008 10:37AM

I'm having a problem imaging our new Optiplex 760 in AHCI mode. I can image the workstation when I set the HD to ATA mode in the BIOS. I can also set the BIOS back to AHCI mode after imaging (of course, I update the following devices with the newest driver.)

What happens is the following:

With the BIOS set to AHCI mode, I boot the machine from a Bart's PE USB drive.

I run ghost and image the machine with XPSP3 that includes all of the drivers needed.

Reboot the machine and the Windows logo with the blue status bar appears.

The machine freezes, and reboots itself into the safe mode selection screen.

What I have found so far is that the following devices are new for this system: (I think these are the culprit)



I have edited our sysprep.inf file to include the following in the [sysprepMassStorage] section:



















The location c:\sysprep\massstorage folder contains the latest Intel Matrix Storage Manager drivers. I've tried the one on Dell's website (Version, A15) for the 760 (Windows XP) and I've also tried the newest driver directly from Intel. The location c:\sysprep\massstorage\old refers to the previous device drivers for devices that aren't included in the new driver. This allows us to image all of the devices we currently have from Dell (D400-D430, D600-D630, D800-D830, E4200, E4300, E6400, E6500, Optiplex SX & GX 270, 280, 620, 745, 755 and now 760.) All of the devices that I listed except the Optiplex 760 are currently imaging fine in AHCI mode (where applicable and ATA mode where not.) We use Bart's PE as our boot environment and I can boot fine in AHCI mode.

I assume my problem is I'm either not listing a device in the [sysprepMassStorage] section of sysprep.inf...


In the newest Matrix Storage Manager, the iaStor.inf and iaAHCI.inf have the following in the [ControlFlags] section: ExcludeFromSelect=*

I think previous versions of this driver have had a specific list of devices in the list, this one has all devices, hence the "*".

**UPDATE: The ControlFlags section does not impact this issue, it merely removes the device listing from certain user interface displays. My bad.

Please feel free to post any/all thoughts as I need to have this resolved ASAP.



Share this post

Link to post
Share on other sites

Figured it out - used nLite to inject the drivers into the Windows XP Pro w/SP2 CD and then recreated the base RIS image install. Deployed the image to the OptiPlex 760 and the Latitude E Series laptops without any issues with the SATA Operation set to AHCI mode.

Ben - let me know if you need help with using nLite. It's a pretty straight forward yet powerful tool. After adding the textmode drivers, I changed my riprep.sif back to what it was before messing with it and our production XP image deployed without any issues.


Share this post

Link to post
Share on other sites


Did you try to do it with XP SP3 and what is nlite? I am having the same issues using ris to create an image for the 760 and E6500 series laptops. I am not using a cd I get the image for Xp from the server. Can you please elaborate . Thanks

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.