Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
cmtptr

Service Pack 3 update broke my wireless?

Recommended Posts

Yesterday I turned my computer on and Windows Update immediately started downloading and installing Service Pack 3, never giving me a chance to stop it (I learned my lesson - Automatic Update is going to be set on manual install from now on!). It downloaded Service Pack 3 over a wireless connection, and wireless has been working fine on this computer for the four years that I've had it.

After Service Pack 3 was installed and the computer rebooted, my wireless does not detect any wireless networks whatsoever, nor will it connect if I configure one manually. I live in a college apartment, so normally I can see about 5 or 6 networks in addition to my own hidden one. Device Manager reports that the card is working fine, there are no obvious error messages in the system log, and I can't find anything wrong with the card's settings - it just refuses to detect any networks. Below are the measures I've taken up to now in attempt to fix the problem:

  • First I uninstalled the drivers, then installed more recent drivers directly from Intel's website. This didn't work.
  • Next I uninstalled Service Pack 3, uninstalled the drivers, rebooted into diagnostic mode, reinstalled Service Pack 3, and reinstalled the drivers. This didn't help, either.
  • Finally I uninstalled the drivers, uninstalled Service Pack 3, then reinstalled the drivers and am currently running without Service Pack 3. It still doesn't work.
  • Yes, the card is turned on, both from the laptop's "on/off" button and from Windows.
  • Somewhere in all of that I also downloaded and installed Intel's PRO/Wireless client. It didn't detect any networks, either, so I uninstalled it and have returned to using Windows to manage my wireless connections since I prefer it.

Service Pack 3 and about 8 updates that came with it are all that changed on my system between "working" and "not working." I really don't know what else to do short of backing up all my irreplaceables and reinstalling Windows, which is obviously something I'd strongly like to avoid... below are my specs:

Clevo M40AE ("Raptor406Z Reactor" from xtremenotebooks.com)

----------------------------------------------------------------------------------

15" SXGA+ 1400x1050 LCD Display

ATI MobilityT Radeon® X700 16X PCI-E with 256MB DDR VideoRAM

NEW! 2.0GHz Intel® Pentium® M "Sonoma" Processor with 2MB On-Die L2 Cache - 533MHz FSB

1024MB PC2-4200 533MHz DDR2 (2 DIMM)

60GB IDE ATA100 HDD 7200 RPM 8MB Cache

8X24X10X24 DVD/CDRW Combo Drive with software (8x DVD/RW available)

WOW! 12 Cell Smart Li-Ion Battery - Approximately 3.5 Hours of Runtime!

110/220V 150W Auto Switching AC Adapter - Included

Sound Blaster Compatible 3D Audio - Included

Generic Integrated System Speakers - Included

Entry Level Black Vinyl Carry Case - Included

Windows XP Pro SP2 with Drivers and Utilities CD

Intel® PROWireless 2915ABG 802.11a/b/g - Standard

Standard 12 Month Parts and Labor Mail-In Coverage

Internal Bluetooth Wireless Mini PCI

4 in 1 Flash Card Reader (SD/MMC/MS/MS PRO) Standard

Let me know if there's any more information I should share that could be helpful. Thank you.

Share this post


Link to post
Share on other sites

You can try these:

(It seems that a lot of users have faced this problem in my place.)

You cannot connect to an 802.1X wired network after you upgrade to Windows XP Service Pack 3

http://support.microsoft.com/kb/953650/en-us

Device Manager may not show any devices and Network Connections may not show any network connections after you install Windows XP Service Pack 3 (SP3)

http://support.microsoft.com/kb/953979/en-us

These are from the results of Google, based on users' blogs or comments.

I don't know if it works to you...

However, one thing is clear that Service Pack 3 of Windows XP could invoke this problem on some computers...

Edited by xlfdll

Share this post


Link to post
Share on other sites

Thanks for your reply. However, neither of these really address my symptoms. I can connect by wired LAN (that's how I'm posting now), and in fact I don't even have SP3 installed right now. Also, Device Manager shows all of my network devices and says they're working properly.

Running my own searches I have also noticed that Service Pack 3 seems to have caused a lot of headache for several people. Unfortunately, I can't seem to find anyone with a solution to my problem...

Edited by cmtptr

Share this post


Link to post
Share on other sites

I have to say, this problem let me have a headache, too.

Although in my searches some people said that use these KB could fix the problem...

(They meet the same situation as yours, and others have a range of different network problems)

But I didn't receive any positive result about it in my searches...

Sorry about that...

I will continue to keep an eye on this problem...

If I found I will let you know.

PS:

It's strange. Because my computers and my friends' didn't have this.

Why Microsoft added a lot of strange things in SP3...?

Edited by xlfdll

Share this post


Link to post
Share on other sites

Well, I've tried something else now that may indicate all efforts are futile.

I came across another hard drive last night which I had used to install Linux a few weeks ago. I had definitely gotten my wireless connection working then, so I swapped out hard drives and booted into Linux. The exact same symptoms were present there, too. The driver loaded fine, the card showed up and said to be working, but it would not detect any wireless networks. At the same time I asked my roommate who is on Windows Vista to see if his card could detect my network, and it could.

So evidently the card is just dead, and Service Pack 3 is not the problem here. The horrible coincidence of it dying during the reboot after Service Pack 3 installed just lead me on a two-day wild goose chase.

Sorry for the inconvenience and thank you very much for your time and attention!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×