Jump to content

NTOSKRNL.EXE missing or corrupt


BigDaddy
 Share

Recommended Posts

first I had Win XP x64 installed and after that I installed Win XP SP3 x32 on the second partition, cos I needed to work on some 16bit apps for school. and for a few days both OSes worked normally. But since yesterday the Win X64 OS will not boot giving me an error:

<windows root> System32\NTOSKRNL.EXE missing or corrupt

but the Win XP 32 works normally.

boot.ini:

[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetect /usepmtimer
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

These are the boot files:

25.03.2005  14:00			47.772 NTDETECT.COM
25.03.2005 14:00 47.772 NTDETECT.COM.orig
25.03.2005 14:00 295.536 NTLDR
09.07.2008 12:21 295.536 ntldr.orig

I have done everything that this guide suggest but nothing has changed:

http://support.microsoft.com/?kbid=314477

and also have overwrited the NTLDR and NTDETECT.COM from my XP 64 CD to C partition, and ran FIXMBR and FIXBOOT from Win 64 recovery console.

Edited by BigDaddy
Link to comment
Share on other sites

  • 3 months later...

I am having bad problems too. I installed XP64 Pro on a 120 Gig EIDE drive, because I cannot make it work (cannot reach the second stage graphical install) on a 160 GB EIDE. I've tried many things, as noted here:

windowsbbs forum posting

and here:

asus motherboard forum

(I cannot log in to Asus forums anymore, and I've tried resetting my password. So probably no more useful posts there.)

What kind of motherboard are you using? I use an AMD 64-bit dual-core, and was told to expand the ntkrnlmp.ex_ from the amd64 directory of my windows disc and to rename it as a drop-in replacement for ntoskrnl.exe. I am told I must make sure the NTFS cluster size is 4K or less, and it is. I tried "LBA mode" in the BIOS, and telling linux fdisk to create a partition table based on that geometry (if you already have a partition labeled "type: NTFS" then XP's install disk formats it [you choose FAT32 or NTFS], but if you have a blank hard drive, XP64 will use the whole drive [again, FAT32 or NTFS, your choice]).

Lastly, years ago, we used software that "tricked" our PCs into seeing drives larger than 8.4 GB. I thought this might be the reason I see a "63-sector offset" mentioned in linux fdisk, and this would fix it. It did not. (And yes, I have tried XP64's recovery console with map, fixboot and fixmbr, they didn't work.)

(When setting the BIOS to "auto", my 160 GB drive has more than 65535 cylinders, I thought this was causing booting issues. But I tried installing on a 120 GB Western Dig instead of my 120 GB Seagate [both around 57000 cylinders], and I had the same problems I had trying to install on my 160 GB. So I have to keep running XP Pro 64 on the 120 GB Seagate, without knowing *_why_* it works or whether I could ever reinstall again.)

If you find a solution to this, please let us know. You are not alone, trust me on that. Answers are hard to find. Good luck!

Edited by saturndude
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...