Jump to content

Sysprep oobe -> computer name <- help !


 Share

Recommended Posts

Hey all, got a problem with Windows Vista and sysprep. I manually installed a Vista Buisiness on a pc, performed some things tweaks/installers so the pc fits me and my co-workers need.

Now, i want to sysprep it with a unattend file so that the oobe is fully automatic, well it almosts works , it just keeps asking one thing , and that's the computername...

I tried several things , like setting "computername" to * or leave it blank... it doesn't matter. Even when i set a fixed name like "testname" it still asks me for the computername during the oobe... Here is a paste of my xml file (as you'll see it's very very basic, cause the only thing i really want is a automatic oobe ...) Anyone got a clue ?

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="auditUser">

<component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<RunSynchronous>

<RunSynchronousCommand wcm:action="add">

<Order>10</Order>

<Path>%WINDIR%\system32\sysprep\sysprep.exe /generalize /quiet /oobe /reboot</Path>

</RunSynchronousCommand>

</RunSynchronous>

</component>

</settings>

<settings pass="generalize">

<component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>

</component>

</settings>

<settings pass="specialize">

<component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<SkipAutoActivation>true</SkipAutoActivation>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<CopyProfile>true</CopyProfile>

<ComputerName>*</ComputerName>

<RegisteredOrganization>test</RegisteredOrganization>

<RegisteredOwner>New Stuff</RegisteredOwner>

<TimeZone>Romance Standard Time</TimeZone>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<InputLocale>0813:00000813</InputLocale>

<SystemLocale>NL-NL</SystemLocale>

<UILanguage>NL-NL</UILanguage>

<UserLocale>NL-NL</UserLocale>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<UserAccounts>

<LocalAccounts>

<LocalAccount wcm:action="add">

<Password>

<Value>egBlAGIAUABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</Password>

<Description>user</Description>

<DisplayName>user</DisplayName>

<Group>Administrators</Group>

<Name>user</Name>

</LocalAccount>

</LocalAccounts>

</UserAccounts>

<Display>

<ColorDepth>16</ColorDepth>

<HorizontalResolution>1024</HorizontalResolution>

<RefreshRate>60</RefreshRate>

<VerticalResolution>768</VerticalResolution>

</Display>

<OOBE>

<HideEULAPage>true</HideEULAPage>

<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>

<SkipUserOOBE>true</SkipUserOOBE>

</OOBE>

<AutoLogon>

<Password>

<Value>UABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</Password>

<Enabled>true</Enabled>

<Username>user</Username>

</AutoLogon>

<TimeZone>Romance Standard Time</TimeZone>

</component>

</settings>

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<UseConfigurationSet>true</UseConfigurationSet>

</component>

</settings>

<cpi:offlineImage cpi:source="wim:p:/workspace/slipstreamer/dvd/vista%20buisiness/sources/install.wim#Windows Vista BUSINESS" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

Link to comment
Share on other sites


If you are running a manual sysprep, then you don't need this in your script:

<RunSynchronous>

<RunSynchronousCommand wcm:action="add">

<Order>10</Order>

<Path>%WINDIR%\system32\sysprep\sysprep.exe /generalize /quiet /oobe /reboot</Path>

</RunSynchronousCommand>

</RunSynchronous>

It might be have a bad effect on your sysprep process to have it in there again, i think.

Link to comment
Share on other sites

Ok , i'll remove that section and try again...

i'll edit this post with my testfindings...

*fingers crossed*

edit : no, still no luck :( It's very weird, cause all the other settings do work (like the timezone, and language options) , just the computername doesn't work :/" (it does also gives me the Vista logo and a "Start" button, like when all the settings are done, don't know if that is of any importance)

Anyone more suggestions ? thanx in advance

edit 2 : Ok i found it ! , and it's a stupid user error (offcourse), when i manually sysprepped i did ,

%WINDIR%\system32\sysprep\sysprep.exe /oobe /shutdown /unattend:c:\windows\temp\settings.xml

if forgot the /generalize :blushing: kinda weird that all the other settings did work ... :)

Anyway : happy ! :)

cya

Edited by korlean
Link to comment
Share on other sites

Have you tried setting SkipMachineOOBE settings to true and tried? Because I have similar problem with my autounattended which would not let me enter my comuter name but everything else seems to be working fine. In my xml file i have set true for both (SkipMachineOOBE, SkipUserOOBE) of the settings and it works for me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...