Jump to content

Visual Studio 2005 is Cluttering My Documents


Recommended Posts

Before I start: this is a Microsoft product forum, we have forums for operating systems, forums for Office and even forums for coding but we don't have a forum for the Visual Studio line of products. Why not?

Anyway, ...

I am trying, desperately, to stop Visual Studio 2005 from creating its annoying, p***y "Visual Studio 2005" folder in My Documents. (Or, in Vista, just "Documents") I have created a folder for it elsewhere, relocated the settings file, the project templates and item templates and the project default location. I have even removed the default Macro projects (which never work) and created my own one in another location, yet it continues to create that folder on startup. The folder remains permanently empty.

Please, this moronic practise of creating folders in My Documents must be stopped! Why can't all developers be like Mozilla and allow you to relocate your profile?

Link to comment
Share on other sites

Visual Studio 2005 is supposed to only create a single folder called "Visual Studio 2005" within your My Documents folder; by default, all projects should be created within that folder unless otherwise specified. Look at your general options to see if that location has been changed.

Link to comment
Share on other sites

  • 4 weeks later...

you'll need to make changes in your Registry. if you

wanna give it a shot, go ahead. as you know, playing

with the Registry can have disastrous consequences, so

think thrice before trying this hack. it worked for me,

but i'm using Visual C# Express 2005. also, backup

both Registry keys before you start. :whistle:

the 2 Registry keys below have REG_EXPAND_SZ values

that reference the location of your "My Documents" folder.



replace said location with a path that points to the

folder you've chosen to hold your VS projects. examples:



NOTE-1: before you change anything, notice that some of

the paths that appear in those 2 Registry keys end with

a backslash ("\") character. for such keys, make sure

your replacement path also ends with a "\". only use the

ending backslash in those values that contained ending

backslashes originally!

NOTE-2: changes are only needed on those keys i

mentioned. dont worry about any of their "sub-keys".

NOTE-3: these changes might require you to register

VS again. it's unlikely, though. i didnt have to.

Edited by nuSharper
Link to comment
Share on other sites

The topic is nearly a month old so perhaps scmartindale has found a solution, but using a junction point comes to mind as an idea to redirect to your other folder and hide the junction point.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...