Jump to content

Xpize causes Hardware installation error


Recommended Posts

Hi guys!

Today I did a new XP installation disc (included the latest MS patches etc). Naturally I also added the Xpize. When I tested the new ISO (before burning) in VMware I get a "Hardware installation Error" (See attached picture for details).

After this I reversed my steps and did just the ISO installation of the XPize on XPP SP2 disc. The error was still present:( I've tried it with a couple other XP installation disks and I got the same error in all cases.

I've tried google, to see if anyone has the same experience, but I didn't found anything, so I've decided to ask you guys for advice what to do.

I really love Xpize and would really like to find a way how to fix this.

Here are the things I used:

XP Professional SP2 (Build 2600.xxx)

XPize 4.7b 2 Full

VMWare Workstation 5.5.2 build 29772


Link to comment
Share on other sites

I've taken a vanilla XP source, slipstreamed SP2 to start with. You're screen shot has the XPize setup screen, so I'm working from the belief that you used XPize to patch the binaries in i386.

I did that as well, and although it did not generate the error during setup, at first login I got a "Device installer error" message: "Windows could not load the installer for Battery. Contact your hardware vendor for assistance."

Taking a look at the SetupAPI log, this error jumped out at me:

#E364 An unsigned or incorrectly signed file "D:\i386\NOTEPAD.EX_" for driver "Battery" blocked....

The exact wording of the error I recieved at first login shows up several times in SetupAPI, each time it followed this error:

#E144 Loading module "C:\Windows\System32\Batt.dll" failed. Error 126: The specified module could not be found.

Thing is, Batt.dll was being used to install a device called "Batteries", while the error message is reporting the device being names "Battery"

Looks like there may be a problem. I'm going to try it on VirtualPC next.

Link to comment
Share on other sites

Today I just found an old copy of Xpize 4.6 (XPize46Full.exe) on my PC and I did another Xpize ISO installation using the same base XP cd as I did before. I then installed it in vmware and this time it's without the battery error. So it seems that xpize 4.7 (XPize47b2Full.exe) has a bug in it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...