Jump to content

Access denied after building WinPE


Recommended Posts

I got a little Problem here, I'm trying to build some scripts for WinBuilder (ever heard of 'VistaPE'? that project is using it too). VistaPE is nice, but I wanted something more along the guidelines of MS. So I tried to recreate the batch files MS delivers with the WAIK within WinBuilder scripts.

Everything went nice and the image is bootable. There is just one disturbing thing, there seem to be files in the building directory, that I don't have any write access to. After installing all the packages available, when I try to delete my working directory, I end up with "access denied" messages (using 'del /F /S /Q workdir').

The funny thing is, not even the "system" account has any write rights on those files, according to the security/permissions tab of the file properties.

So my only way to get rid of the directory is to boot to another OS and delete the files from there.

Did anyone else run into this problem?

Link to comment
Share on other sites

  • 4 months later...

I forgot to make a follow-up to this post. Here is how I solved the problem for me:

Use a working copy of the base image (thats what copype.cmd is for). Mount the working copy of the image with /mountrw to an empty directory. Make your customizations, /unmount /commit and /export the image after that to get the size down (set /compress as you need).

just don't use the /apply method (applying the image to a folder and recapturing it), I found no way to get arround the ACL issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...