Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Strange problem with 16-bit programs


Gompedyret
 Share

Recommended Posts

Hi, guys.

I have a small collection of old games which is installed with my customized windows. Examples of these are Slam! (pic in the bottom) and Colonization. The problem is that as soon I conjure up a menu from these games (either from the menu bars directly or by right-clicking) the game just exits. Sometimes I can get the glimpse of an error message, but I'm nowhere near being able to study it.

Recently I got the bright idea to use CamStudio to record such an incident and finally the error was "caught on tape" (Pic below) As you can see, there's nothing special, just the standard "something effed up in windows" report.

post-150322-1196055166_thumb.jpg

It goes without saying that this is quite annoying. Especially Colonization is tiresome to play when every use of the menu crashes the game. Also, I hate to not have the faintest idea what _really_ is wrong, so therefore i come to you, brilliant and clever guys. This can't be a unique problem, I reckon. I have tried googling, but I'm not really sure what to search for (english is not my native language) it kind of didn't return anything of value.

- As stated, they all seem to be 16-bit programs

- I overclock quite heavily, but I clocked down and tried again, same result.

- Specs: WinXP pro, Dot Net 1 and 2, latest java, bunch of progs as well as the most recent update pack from Ryan

- Nothing shows in the event log.

- Compatibility mode doesn't make a difference.

- The system is a modified installation with nLite, SP3 or SP2 doesn't seem to matter, same fault with both. The "run 16 bit programs in their own memory space" choice in nLite doesn't make any difference.

-could it be a service that doesn't work the way it should? I have deviated a bit from the standard set-up, though nothing radical. Error reporting service is set to automatic.

- I have done one registry tweak that removes pop-up balloons, and this tweak, to speed up file management:

		 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
"NtfsDisable8dot3NameCreation"=dword:00000001
"NtfsDisableLastAccessUpdate"=dword:00000001

So the question is, what causes my 16bit programs to malfunction when the menus are called? And as a bonus question: Why does the error report abruptly disappear?

The installation has a bunch of programs installed as well as quite a few registry tweaks, mostly from MSFN. I have mentioned a few obvious ones, but very possibly there are other tweaks that may have such an effect. If noone is familiar with this kind of behaviour, I'll take the question to the nLite forum. But I just refuse to believe that this hasn't happened to others as well.

So please report if you know or suspect anything! Of course, I'd be happy to give any information required. This is really baking my noodle, so I'll be very happy for any help.

Cheers.

post-150322-1196055160_thumb.jpg

Edited by Gompedyret
Link to comment
Share on other sites


Have you tried running these in something with good VESA emulation, like DosBOX? Since the 16bit subsystem runs inside the 32bit ntvdm.exe, that error message is coming up from the ntvdm.exe process, and not command.com (which is running your app in a "virtual machine" of sorts).

I would also STRONGLY suggest that you disable the previous tweaks, as they wreak havoc with 16bit apps.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...