Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


usmamyer

Member
  • Content Count

    1
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About usmamyer

Profile Information

  • OS
    Windows 10 x64
  • Country
  1. Hello all. I've been dual booting for a long time and have never had any issues using Windows 7 and Ubuntu or Kali in the past as dual is very easy. I recently decided to set up my laptop to triple boot Windows 10, Ubuntu 16.04 LTS, and Kali Linux 2016.2 64-bit on a single drive in my laptop. I decided to use this method because i prefer it over a virtual machine and can easily separate my work areas from my play ones. I did experience some slight issues during installation and thought I had everything sorted, but there are some slight discrepancies in boot and performance that has me thinking I may have done something improperly and have not been able to find just the right answer anywhere yet. This is what I did. System Specifications Model: Acer Aspire E 15 (E5-571-563B) Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz × 4 Memory: 6gb Graphics: Intel Haswell Mobile Disk: 1tb fdisk -l output: This pc originally came with windows 8 which i found generally useless so I formatted and installed Kali 2.0 by itself to use as a penetration tester until deciding to make it triple boot. All installations were conducted from a USB drive with each OS on them individually using Rufus 2,1, GPT UEFI, Fat32, and official ISO's for each. Installation Process and issues: 1. Delete all partitions and format full disk 2. Installed Windows 10 Enterprise without a hitch. 3. Installed Ubuntu 16.04 LTS without a problem. 4. Changed BIOS boot order to put ubuntu grub2 before Windows boot manager 5. Had issues getting Kali Linux 2016.2 to boot in UEFI after trying multiple suggestions to get it to do so, so... 6. Used Ubuntu installation's Startup Disk Creator and the Kali Linux 2016.2 ISO to create Kali installation drive. This is the only way I was able to get the Kali image to actually boot. 7. Kali 2016.2 seemed to install just like normal including saying it updated grub info and everything, used the option home folder and system on one partition recommended for new users. 8. Upon reboot I was able to boot from Win10 and Ubuntu, but Kali was not listed, so I booted into Ubuntu again and employed the Boot-repair program using recommended settings. 9. Rebooted and was now able to see my Kali installation on the list as well as a couple unknown listings like windows boot.efi type entries which simply reboot to the grub2 again but every OS does boot. 10. Booted into Windows and updated all drivers and windows system 11. Booted into Ubuntu and updated/upgraded dist/packages/drivers 12. Booted into Kali and updated/upgraded dist/packages/drivers I noticed it seems to take a little longer to boot Ubuntu than I believe it should but it does not give me any errors. everything seems to operate properly but seems just a little slower than expected for sure, and I noticed that regardless of what OS I am running, whenever I open a new Firefox window, they all use the home page of "data:text/plain,browser.startup.homepage=file:///usr/share/kali-defaults/web/homepage.html" and the page below reads "browser.startup.homepage=file:///usr/share/kali-defaults/web/homepage.html" without quotes. This makes me believe maybe my partitioning is out of order somehow or I missed/damaged a setting with boot repair in the Ubuntu environment (i did not use boot-repair from a live cd/usb environment, I booted into the Ubuntu already installed on my disk to run it.) I will generate a bootchart image soon and provide it here as well if that would help, but i figured i have to ask someone who knows more about this than me as I have tried every suggestion I was able to find so far and have yet to find an explanation as to why things are the way they are. Please let me know if there is anything else I left out or need to try to get this worked out. Thanks in advance for your time and assistance.
×
×
  • Create New...