Jump to content

pjb0222

Member
  • Posts

    2
  • Joined

  • Last visited

  • Donations

    0.00 USD 
  • Country

    United States

Everything posted by pjb0222

  1. This requires an elevated command prompt or run logged in as administrator post image. First, copy your theme file to "C:\Windows\Resources\Themes" so it shows up in the list of themes for all users. Alternatively you could put it in the default user profile but keeping up with that becomes bothersome. Next pick which method you want to protect the file. Either will prevent the file from casual deletion as TrustedInstaller is the only ID with deletion permissions and administrators cannot elevate then delete. They will need to modify file permissions first (which is why you do not need to deny deletion). Method one requires you to take ownership of the file prior to modifying permissions. This adds one step to the process but if you are in the GUI you have to close out of the file properties after taking ownership before proceeding. From the command line while it is trivial to add the take ownership into the script people tend to forget steps later on. Simply for ease of management I recommend method two. Method two (recommended) changes this by adding write permissions to administrator. You don't need to remember to take ownership to update permissions. Method one ICACLS "C:\Windows\Resources\Themes\NAME.theme" /setowner "NT SERVICE\TrustedInstaller" ICACLS "C:\Windows\Resources\Themes\NAME.theme" /grant:r "NT SERVICE\TrustedInstaller":F System:RX Administrators:(RX,WO) Users:RX /inheritance:r Method two ICACLS "C:\Windows\Resources\Themes\NAME.theme" /setowner "NT SERVICE\TrustedInstaller" ICACLS "C:\Windows\Resources\Themes\NAME.theme" /grant:r "NT SERVICE\TrustedInstaller":F System:RX Administrators:(RX,WO,WDAC) Users:RX /inheritance:r I recommend that you leave the administrators group with at least TakeOwnership rights. Otherwise you may find yourself with a file you cannot delete short of reformatting the drive.
  2. The problem is starting with Windows Vista, Microsoft changed how DNS lookups are handled. Specifically DNS devolutions and unqualified names. There are two (2) changes. 1. This issue may caused by the different DNS resolve behavior between XP and Vista/7, below are the details: Windows XP: By default, when a machine attempts to resolve unqualified multi-label names, the DNS client will attempt to resolve the name as specified, then append the domains that are listed in the DNS suffix search order. Windows Vista/7: By default, when a machine attempts to resolve unqualified multi-label name, the DNS client will attempt to resolve the name as specified. The DNS suffix search order will NOT be used. Domain Name Devolution http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/93802.mspx?mfr=true You can change this sith GPEdit or add the registry key. There is a second DNS change on resolution but this usually covers 90%+ of the issues. Run the gpedit.msc on Windows Vista/7, then expand to Computer Configuration\Administrative Templates\Network\DNS Client. Under there, enable the option "Allow DNS Suffix Appending to Unqualified Multi-Label Name Queries." Restart the computer and try again. HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters UseDomainNameDevolution = dword 0x1 2. What is an unqualified multi-label name: The name specified in the query contains a dot(s), but is not dot-terminated. To resolve it, try to run the gpedit.msc on Windows Vista client, then expand to Computer Configuration\Administrative Templates\Network\DNS Client. Enable the option “Allow DNS Suffix Appending to Unqualified Multi-Label Name Queries” under there. or HKLM\Software\Policies\Microsoft\Windows NT\DNSClient AppendToMultiLabelName = dword 1 Edit: Found my notes and added references and reg keys.


×
×
  • Create New...