Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


  • Content count

  • Donations

  • Joined

  • Last visited

Community Reputation

0 Neutral

About JackCarver

  1. Hehe ist works too in isolinux.cfg: kernel /BOOT/grub/grub.exe --config-file="kernel (cd)/platform/i86pc/kernel/unix;module=(cd)/BOOT/x86.microroot;boot" and solaris boots like a charm. Jack
  2. I got it ... I tested a little time with the latest version of grub4dos and i found out the following: The latest version cant find menu.lst if u do it like the version before. There you needed only kernel /path_to/grub.exe in ur isolinux.cfg. Now its kernel /path_to/grub.exe --configfile=(cd)/Path_to_menu.lst if u want ur splashimage its now splashimage (cd)/path_to_image.gz in ur menu.lst. otherwise grub doesnt find it. dont know why they made it so complicated compared with the older version i tried first but this works. then for example when u want to start vistaPE directly use: kernel /path_to/grub.exe --config-file=chainloader (cd)/path_to/BOOTMGR and PE starts directly without going in menu.lst. Btw u must use chainloader (cd)/path_to/BOOTMGR in ur menu.lst as well. without the (cd) the chainloader directive doesnt work. now i will test if its also possible to start OpenSolaris directly from the isolinux.cfg via grub. perhaps i can paste the kernel and module command from menu.lst directly in the isolinux.cfg. if it works i write it here in the forum greetings Jack
  3. Hmmm did a little testing of my own. The command you posted doesnt work. when i add APPEND --config-file="CHAINLOADER /BOOTMGR" in my isolinux.cfg nothing happens. But even more strange, when i use the grub.exe from the latest Grub4Dos Build i get the error: Booting find /menu.lst find --set-root --ignore-floppies --ignore-cd /menu.lst Error 15 File not found... i think this happens cause of the --ignore-cd directive. the version before this one finds menu.lst without problems. dont know how i can change this, that grub doesnt use --ignore-cd or so. Jack
  4. Hi Jet, i downloaded only the grub.exe file of the package Grub4DOS. As said I had the problem, that OpenSolaris 10 comes with a Grub bootloader. So i searches a pretty time the web to find a solution, that i can start grub via Isolinux and then i found this article: http://aronzak.wordpress.com/tag/syslinux/ Look at the topic "Howto: Syslinux and Grub on one USB drive" at this site. There you can find the link i downloaded the grub.exe. I think you can also use the grub.exe from the lateset Grub4Dos package as well. To my DVD structure: I have a folder calles BOOT, i chose this cause Vista has this folder on DVD. In this folder i have the dirs "isolinux" and "grub". In the "grub" dir i put only the grub.exe file, in my "isolinux" dir there are all files which isolinux uses as isolinux.bin, ...cfg and the kernel and ramdisk files. In my root directory, i called it "Multiboot2" - as i now decided to make one Multiboot-DVD only with Live-Systems as knoppix and so and one with Systems to install on HD - there i put the grub menu.lst file and the splashscreen file as Grub4Dos seems to search in /root_dir, /grub, or /boot/grub but not in /BOOT/grub as i have. Now to start grub from isolinux put a directive as: LABEL VistaPE OpenSolaris MENU label 7 VistaPE OpenSolaris V10 (Grub4DOS Prompt) kernel /BOOT/grub/grub.exe in your isolinux.cfg file. As grub.exe is a linux kernel you can put it in the kernel directive of isolinux.cfg. This directive now starts Grub4Dos and it searches for its menu.lst and splashscreen if you want to have one in the grubmenu. I took the menu.lst from OpenSolaris and made some new entries in it to start VistaPE, as example: title VistaPE chainloader /BOOTMGR title OpenSolaris 2008.11 snv_101b_rc2 X86 kernel /platform/i86pc/kernel/unix module /BOOT/x86.microroot Thats it. Right after you push the VistaPE OpenSolaris Button in the isolinux menu, grub starts and shows its submenu with this entries. There choose your favourite and VistaPE or OpenSolaris boot. Pls let me know when you did some testing if this works for u. For me its a nice combining of isolinux and grub4dos as grub4dos is better in chainloading other bootloaders in my opinion. greetings Jack
  5. Hi Jetman, wanted to say thx. Great Article you wrote here. I was able to integrate by now the following os on one DVD: Vista, XP, Knoppix, Knoppicillin (Linux Virus scan), Open Suse 10, Fedora (Live cd), Open Solaris 10, Gparted, Acronis Disk Director, Acronis True Image, Debian Squeeze CD1 (testing) and DSL. Tricky was the OpenSolaris integration because OpenSolaris needs the Rock Ridge Extensions to boot and the grub Bootloader. The problem was, that WinXP cant boot when i activate the -r switch in genisoimage. I read that the XP bootsector would be destroyed with Rock Ridge enabled. Dunno why or if i made another mistake. So i need a workaround to get both Open Solaris and XP to work. And the solution was Grub4Dos as it can directly start the NTLDR of xp without using the Bootsector via a chainload directive. The grub4dos package contains a file named grub.exe and this file is actually a linux kernel. So as i didnt know how to chainload other bootmanager via isolinux you can indirect start grub via isolinux with kernel grub.exe Then you have the ability to chainload via grub SETUPLDR.BIN from the i386 folder and this starts NTLDR. Thats it, and it works with Rock Ridge enabled. So you can start via the isolinux menu both WinXP and OpenSolaris via grub and both works with Rock Ridge enabled. JackCarver