Jump to content

stsaerox

Member
  • Posts

    49
  • Joined

  • Last visited

  • Donations

    $0.00 

Posts posted by stsaerox

  1. I haven't used your application for years, today I've tried to update it because every time I reinstall windows on my computers, your app makes the procedure fan (and fun is also updating the apps in it for me)

    Its so sad to see that this project is abandoned you and this didn't get what it deserves, at least I hope that you moved on and did something else more creative and more fun for you.

     

    Sorry for my English I'm from greece

  2. I need network support for my family's computers so I don't have to copy the whole stuff 600mb+ with small files that takes time to copy as you know. (edit)If also a friend brings his laptop(s) to my house I will be able to reinstall withought to waiting to eject flash drive or copying procedure.

    I was meaning that network administrators will be happy but a proper wpi will also release our hands too in a home network. If you disable it I'm with you I agree It's a powerful tool, too hard to support. I've already read about the licencing and if could I would suggest more ideas for protecting it. I have a very good friend who is a android app developer and I know how it is going...

    Well no I do not have business or being an employee somewhere. I wish I was because even me can do better work sometimes. As you may noticed in my last posts I can hardly write a cmd command... I'm making unattended for fun mostly. When reformatting a friends pc I have to be in his home for 4 hours and I have to remember all and do all because they don't know even the basics and most times there are many lose ends.

    About vlc I didn't have a clue what to install in my amd64 3500+ 1gb ram. I had my xp for years now. I've installed a 30 days trial x64 system but ram was not enough. And now each or half year I'm installing either my old xp pro or 7 home premium x86 an I was thinking to try xp x64 but I have no clue where was the last time I found 30days trial xp...

    I have an old pentium 2 which needed nlited xp to the bone and the light version of winamp when the others two can run winamp new.

    Also others have one system or another.

    Most people I met even in a computer store services learn about wpi from me. They don't even know it and I suspect they don't know about unattended installation a thing in my country.

    (Edit) Until now Ι haven't used wpi for nothing. I've first tried since 8.1.0 version and I've been for a year or more trying to make it work. I was trying to use it along with command: "for %%a in (*.exe) do "%%a"" to update easily. Without this it was just the same for me to add in sfx each program and run from runonce with "for %%a in (*.exe) do "%%a"" to install some dropped in the same folder sfx. I have learn before one or two weeks how to make it work with this command.

    (Edit)Also I belong to doctors family. They would never leave me as a kid to follow anything else. I did not make it but I'm just working in paramedics Sector.

    (Edit)I shared more information than I had to. I hope you respect it.... When I use this application and do what I like generally: "helping people" Then I'll support you and this project with the only way I can....

  3. Tested like this and works fine for me:

    Run.bat


    @echo off
    echo Installing Java
    for %%a in (%wpipath%\Install\JAVA\*.exe) do "%%a" /s

    Run.bat and jre-7u4-windows-i586.exe are inside the same folder JAVA

    If I run a command like this and wpi is not at the root of the drive it fails. Is it the way that just wpi works or I've done something wrong?

    (I'm asking this because in every suggested path in help files I've read, wpi folder is at the root of a drive)

  4. I'm trying also to add multiple conditions. For example:

    getBits()==32, getOSver()=="Win7"

    How these can be separated? Like above will really work?

    Use "&&" to separate them

    getBits()==32&&getOSver()=="Win7"

    According to this I've tried something else but the batch will not run... Can you help me?

    {x64}&&{BATCH} "%wpipath%\Install\sys\TU\Installx64.bat"
    {x64}&&{BATCH} "%wpipath%\Install\sys\TU\Installx32.bat"

    In x86 system it normally skips x64 command but the the x86 fails.... Does logical operators "&&" work in commands tab or only in condition tab?

  5. There is no " team " it's mainly just me. Yes there are a couple of members that have been posting mods.So all of the info I write here is useless? I am just supposed to answer everyone who cannot be bothered to read even the first couple of sentences of the first post in a release thread?My crystal ball has been broken for quite some time. Your post mentioned nothing of the issues you were having in details that would actually show you were doing more than just complaining.I guess I can now delete the manual to? Hey that's all just useless, wasted effort then, right?

    No but people think different I know english I have a degree but never truly used them. I cannot understand always, like I do with my mother language but that's my problem.. I know. I've read your info that's why I can use wpi about 2 years now for XP. I need some help that's all because I have to use it for win 7 and xp also now.

    Wpi is ok as it is no complaints...

    I've checked that fixed network related components or something is fixed. I'm using a network between xp and 7 and I've been in running generally in troubles not only with wpi... I'd just like to know if there is known bugs in wpi that I cannot handle and have to wait.

    If you fixed this many network administrators may be happy. A proper wpi always releases our hands.

    Updating from 8.1.0 failed.
    Tested and I have no errors!Launch WPI 8.1.0 and select: About WPI and click on Check for update and download the new WPI 8.6.3.

    The first think I noticed was that I have to move the script files to other directory that's what I found first and did in a new version's thread ... I thought until now that normal update won't work from 8.1.0. Note also that I had some commands in the older version that are not working with the newer...

  6. Ok they are in chapter 7 but even now I cannot understand how could I use them or where. I know some english but to get the reasoning I need examples in some cases.

    Comparison operators

    ">" Greater Than

    "<" Less Than

    ">=" Greater Than or Equal To

    "<=" Less Than or Equal To

    "==" Equal To (not "=", which assigns a value to a variable.)

    "!=" Not Equal To

    I'm ok with && but none of the above I Know how to use. I'm not asking right now for examples... Just mentioning...

  7. Yes but I got error when I was try to update. I could not even get update info instead I get an error screen about the script not responding. After a computer restart It was ok that's why I asked. First I think was to check if it really an update or something else because your site was not updated, only this post.

    Updating from 8.1.0 failed. At first I run the batch and then tried manually with instructions from the read-me I think. I always got a script not responding error and a blank wpi. I had to enter commands from the beginning to the newer version... I thought that again I'm missing something

    I thought also that was the forum for... to ask questions to get straight something... I always get that type of answer from you. We are not in your head because maybe we are not your team. If you don't like to answer there are other member that can answer. I'M NOT DEMANDING anything from you.

    Also some people are trying to learn as you did, I suppose, before you built wpi.

    For me and for most people is more boring to write than searching or reading. We are not doing anything on purpose. Maybe we entered wrong search criteria...

  8. It keeps failing for me maybe something is wrong with my wpi now. I'll try to make a new one and run the batch.

    Edit: In the latest (8.6.2) It seems ok, I get success message.

    Edit: At first I had some path mistakes and It didn't work but now it is ok. Thanks myselfidem. I 've read many times about commands but when I combine them I get confused.

    This is awesome for me, now wpi will be my right had. I help many friends with windows installation because services there are no good and expensive.

    And there is great effort made to the latest wpi.... thank you.

  9. Is it really? I cannot figure out my mistake.

    This is how I select the path so I won't make a mistake with paths:

    http://www.youtube.com/watch?v=FfT6h7G0jyc&feature=youtu.be

    if you mean the path IN the batch file I have no idea how to fix this but if double click it runs and installs ok.

    My full path there is "E:\Programs\Install\Projects\WPI ALL\WPI\Install\WinExt\Java" In java is bat and exe file.

    I'm just building this in there if use it I will move it to a flash memory stick.

    Edit: Can you see my video in this post? I cannot see that. If no please try this.

    Windows post install - cannot run batch with "for" and ''do" commands.

    oh what is happening? third edit and no video at all....

  10. I'm trying for a long time now to run a batch file:

    @echo off

    echo Installing Java
    for %%a in (*.exe) do "%%a" /s

    with this command typed in wpi:

    {BATCH} "%wpipath%\Install\WinExt\Java\Run.bat"

    It fails instantly.

    Well if this command work somehow it will be a great progress in updating the unattended installation executable because I have to replace only with the newer executable and not change the commands for each file. This method if work saves time updating.

  11. I'm trying to add this batch file to wpi but it does not run...

    @echo off

    echo Installing Windows Live Messanger 2011 only

    for %%a in (*.exe) do "%%a" /q /NOToolbarCEIP /NOhomepage /Nolaunch /nosearch /AppSelect:Messenger

    In the folder there is wlsetup-all.exe that it is meant to run. The cmd window cames up but it closes instantly before the program finishes installation.

    When running the batch file manually it is working correctly.

    What's wrong?

  12. Der I am really sleep deprived.

    WPI doesn't handle bat files quite right.

    Change your commandline to this:

    {START} "%wpipath%\\Install\\7-Zip-(32-bit).bat

    Then Bobs your uncle...

    (Worked fine here for me now.)

    Ahh okay, thanks for helping me out. Now I certainly know not to use brackets in these file names.

    I found out that your start command would actually also work with some moidification.

    {START} cmd /c "%wpipath%\..."

    But its much easier code when skipping brackets.

    What's the difference?

    {START} "%wpipath%\..." AND

    {START} cmd /c "%wpipath%\..."

    What does the "cmd /c" does?

    NEVER MIND I FOUND IT: http://ss64.com/nt/cmd.html

  13. .... Seems to be difficult... then...

    Does this vbs script below help to add this future on your next wpi?

    Option Explicit
    Dim fso, fc, f, fs
    Dim strPath, strFile

    'On Error Resume Next

    strPath = "E:\Users\Stefanos\Desktop\versions.txt"

    Set fso = CreateObject("Scripting.FileSystemObject")

    Set strFile = fso.CreateTextFile(strPath, True)

    strFile.WriteLine("FileName,Last Modified,File Version")

    Set f = fso.GetFolder("E:\Users\Stefanos\Desktop")
    Set fc = f.Files
    For Each fs In fc
    If fso.GetExtensionName(fs) = "exe" then
    strFile.WriteLine(fs.Name & "," & fs.DateLastModified & "," & fso.GetFileVersion(fs))
    End if
    Next

  14. Hello

    I've just tried to make my wpi. It would be very useful if in "tooltips" section had the option to show executable's file version, or the best is the details tab of files properties. Maybe thats difficult I know but it could get easy when somebody updates the wpi frequently with app's latest version because he don't have to write the version of every single app.

    That's one common inconvinience in making unattended installations I think.

  15. Hi All,

    I created a silent install of one of the applications via winrar sfx and put "Shortcut=D...." command line in SFX comments.

    so far so good its working fine.

    but now i want to place this shortcut in %systemdrive%\AllUserProfile%\Desktop. Can anybody help me with the command line for the same?

    Thnx in advance..

    I'm trying to make shortcut in "%AllUsersProfile%\Start Menu\Programs"

    But I don't now how to add the command in a winrar sfx. Can you help me?



×
×
  • Create New...