Jump to content

cb3dsl

Member
  • Posts

    15
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    United States

About cb3dsl

cb3dsl's Achievements

0

Reputation

  1. OK I got the hive load working now. Thanks man. Got winrar associated with rar and zip files at least. The loading and unloading is getting tedious though. Anyone know of a hive direct editor that is similar to the regedit structure?
  2. I am using bartpe on a sandisk cruzer flash drive and I have just used the base pe build until now. I have added alot of apps for recovery, most of which are standalone and dont require registry entries just dlls, but now I am experimenting with some basic system setup applications and alot of the programs im looking at are alot more complex. The main issue I am having is I dont want to rebuild bartpe on my UFD everytime I add a new app but I cant figure out how to get some of the apps working. I am trying to add acronis disk director and I have all the files in place but it still will not run. (Comes up with an error about cant locate acronis modules) I have done some research and it seems to be missing quite a few registry entries. Also I have copied winrar from my main pc and I can run it but when I set the associations in winrar to make extracting easier it doesnt save the registry settings so once i reboot i have to either just open winrar and work from inside it or reassociate it every reboot. I have tried using rundll to manually install the bartpe plugins as they look similar to normal driver installation inf files but its either not the proper formating or its not saving the changes. So I guess what im looking for is information on how to either push winpe's registry changes to the UFD before reboot or a way to convert bartpe plugins to a format that I can install/merge from within winpe. It seems most program installers work fine within winpe and the program works great until I reboot and the registry settings are lost. I have gotten vlc player to work by just running the installer from within winpe but after the first reboot I lost the file associations. The program works fine though although i still have no sound but thats another subject. The installer technique would be great if I could get winpe to push the registry changes to the disk. Can anyone elaborate on a way to merge changes into the registry from within winpe and have it stick? Thanks in advance
  3. well they may be strict but at least they are **** good at it lol take into consideration that this site is pretty large and extremely active for the number of mods they have and still not much slips by them
  4. you can make a bootable cd for true image or any low level acronis application using the create bootable media option in true image then once you boot with that cd you can restore whatever images you got on to any drive on your system ive tried running acrnois partition expert from a bartpe session but couldnt get it to work correctly which may be because of the resource limitation or may be because it needs special drivers loaded on the system to function correctly although i tried to copy in and register the files that i noticed it copied in the install process i never was able to get it to run directly from win pe besides its much easier just to make a bootable cd from acronis and then copy that and the boot image from that cd to your win pe cd and make it a multiboot cd and you still have the full gui that is included in the windows version so its no different to use it that way
  5. hmm i tested it today and it wont work on a newer sound card that i have it works for me on my test machine because i have an old pnp dos compatible sb card and i havent really tried it with other pcs that much except from a win 2000 upgrade for a friend which it worked on (no clue on what kind of sound card he has) i use the winamp 5.03 msi file http://www.msfn.org/board/index.php?showtopic=17412 allanol is right though it probably wont work on any 32 bit sound card i wasnt sure about the drivers not being loaded at that point but if you do happen to have a sound card that it works on youll need to use the msi and install it on a pc then copy the install directory it to the $OEM$ folder and then execute it from where you copy it to on the hd within the setup process youll also need to copy over the music you want to listen to and edit the winamp.m3u playlist file to point to those files (ive noticed it wont let me browse for a file at this point in the setup process) all settings are handled by the winamp.ini file so make your changes there if needed... as far as i can tell no registry calls are made by winamp and no settings are stored in the registry so thats not a problem but personally i like the idea of running freecell or solitaire or some other portable game exe file in detached program... just something simple to amuse you while windows setup does its thing but anyway ill stop rambling now
  6. @ nuhi ok heres the files you need i got: a full listing of the missing files for this configuration the selected.ini file the nlite.log file debug_info_for_nuhi.rar debug_info_for_nuhi.rar
  7. jut some fyi for those finding that nlite is hanging ive found that it extracts a large amount of data to the xp-cd folder and if your drive is not big enough to hold all of it it will not show any error.. it just stops i had the xp-cd folder on a 1 gig drive with the oem setup also in there (bout 680 megs with the oem and a standard sp1-slipped i386 folder) i was trying to figure out why it kept hanging and finally i looked at the drive space and saw it was at 0 bytes free space it took me a few times before i realized it was filling it up when i moved the xp cd to a 3 gig drive everything worked fine edit: @nuhi oh and i also think ive figured out why its hanging when you have the i386 folder in the root af a drive i would assume the remove folder checking function checks for any folder perallel to the i386 folder and being the System Volume Information folder is also in the root its gets denied when it looks at that folder and it errors out becaues it cant access it and im still getting those file missing errors in the copying process of the textmode setup is this normal or should i try making an iso within nlite? im using nero 6.3 to create an image of the lightened i386 folder instead of making an iso from nlite mainly because nero is quick to make an image with and i can include the boot file pretty easily it looks like most of the files that are missing are from the drivers section... ie: modem.sys tosdvd.sys fsvga.sys usbcamd.sys usbcamd2.sys etc.. theres also a few fax files that it keeps looking for i have most (but not all) of the drivers section checked and ive turned off faxing, system restore, folder indexing, and the entire language section just wondering if maybe i can edit something to make it not look for these files? i tried editing the DRVINDEX.INF file and even the DOSNET.INF file and its still looking for those files i tried editing the layout.inf file and windows setup errored out saying the signature is missing on a setup file (it didnt say which one but the layout.inf file was the only one i edited in that test run)... im at a loss for how to fix this anyone have any ideas?
  8. the root problem is not something i would worry about most of us wont ever use it in the root of a drive anyway simply because windows adds the recycle bin and system info. folders in there i havent gone in depth on seeing why its doing it for me (but it could just be something within my system, some app/driver ive installed or something maybe) but if i have some spare time i may look into it and about those entries if you want i could help with listing all the entries that are missing with each reduction set if you want il have plenty of time tomorrow and over the weekend to play wiith it... just let me know if i could be of assistance in the beta testing looking forward to the next version this is going to become an awesome addition to any admin/utils collection
  9. im seeing the same thing with my install ive removed alot of the useless drivers but it seems the references havent been removed so windows is still looking for them its not going to harm anything that these files are missing cuz windows does not REQUIRE them but is it supposed to be like this or is this a bug? i realize this is still beta so he it might not be finished coding everything just yet i hope this can be fixed and thanks for the awesome app EDIT: btw i found a bug when you are reading the xp cd directory into nlite from the root of a drive it produces an "unhandled exception" error debug info to follow See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box. ************** Exception Text ************** System.ArgumentException: Invalid File or Directory attributes value. at System.IO.File.SetAttributes(String path, FileAttributes fileAttributes) at ..(DirectoryInfo ) at ..() at .. () at ..(Object , EventArgs ) at System.Windows.Forms.Control.OnClick(EventArgs e) at System.Windows.Forms.Button.OnClick(EventArgs e) at System.Windows.Forms.Button.WndProc(Message& m) at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) ************** Loaded Assemblies ************** mscorlib Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.573 CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll ---------------------------------------- nLite Assembly Version: 1.0.1608.385 Win32 Version: 1.0.1608.385 CodeBase: file:///C:/Program%20Files/nLite/nlite.exe ---------------------------------------- System.Windows.Forms Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.573 CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll ---------------------------------------- System Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.573 CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll ---------------------------------------- System.Drawing Assembly Version: 1.0.5000.0 Win32 Version: 1.1.4322.573 CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll ---------------------------------------- ************** JIT Debugging ************** To enable just in time (JIT) debugging, the config file for this application or machine (machine.config) must have the jitDebugging value set in the system.windows.forms section. The application must also be compiled with debugging enabled. For example: <configuration> <system.windows.forms jitDebugging="true" /> </configuration> When JIT debugging is enabled, any unhandled exception will be sent to the JIT debugger registered on the machine rather than being handled by this dialog. REEDIT: correction its not ntfs compressed volumes its when your reading in the xp cd directory from the root of a drive it apparently doesnt like this
  10. ive done something similar to that but i use winamp 5.03 for my install winamp is pretty good and it doesnt use registry settings it uses ini files so it can pretty much be run from anywhere you just have to make sure you have your sound card drivers loaded up which they are probably already loaded if your coming from winpe or you can just add them with the oem pnp path setting in the winnt.sif file heres what i have setup add this script for loading winamp with some music and it can even load a playlist up for you MD "%systemdrive%\My Music" MD "%systemdrive%\Program Files\TempAmp" copy /y "%cdrom%\My Music\*.*" "%systemdrive%\My Music" > NUL copy /y "%cdrom%\Winamp\*.*" "%systemdrive%\Program Files\TempAmp" > NUL "%systemdrive%\Program Files\TempAmp\winamp.exe" "%systemdrive%\My Music.m3u" copy all your music to the my music folder on your cd and then copy winamp to the winamp folder on the cd making sure you delete the skins you arent using (and of course youll need a way to add the cdrom variable) now winamp will run til you reboot to go into the final setup stage this will load all the songs that you have placed in the my music directory since winamp will parse directories for all the files in it and load them all you can delete the files with a reg key in runonce calling a cmd file to delete the my music folder and the tempamp folder that was created if you want to do automated cleanup after install is finished rmdir /s /q [folder to delete] i havent tried a video yet but i dont think it would be a prolem either considering winamp processes all the media with its own code instead of runtimes i dont think winamp has any external dependencies so it should be able to read most anything
  11. hello ive been reading stuff on this site for a few weeks now and i must say this is the best site ive found for windows install modifications ive recently started trying to make a custom xp disc with things like the latest drivers for my mobo and graphics and all those little necessary apps however im having a problem getting the cmdlines.txt file to run im pretty sure i have everything in the right place however i have not modified the winnt.sif file (didnt know if i needed to or not). i think i remember reading that it didnt need to be called from anywhere and that the sole presence of the $oem$ folder would let it know to look for the cmdlines.txt file but i may have read wrong or overlooked something if this is the case then how could i modify/make a winnt.sif file just enough to make it copy the $oem$ folder and run the cmdlines.txt file but still have it not be "unattended"? i wouldnt mind getting some of the useless screens liek the eula and the time zone settings out of the way but i still want to keep things like workgroup/domain name and usernames (if thats at all possible) because i will probly be installing this on other pcs as well also might you know of any good links for the winnt.sif file that documents all the settings and proper uses? i guess what i really need is just a point in the right direction any help would be greatly appreciated thanks


×
×
  • Create New...