Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


chrislynch

Member
  • Content Count

    8
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About chrislynch

  1. Yes, I'm well aware of the error message when you run setup manually. That's why I'm asking if DISM or another method can be used to upgrade the OS without a complete re-install or V2P2V.
  2. Is it possible to upgrade Windows Server 2012 to Server 2012 R2 when Native VHD Boot is used? So far I have found it's not possible. I've looked through the DISM documentation and it mentions offline updated, but I do believe that refers to OS patching, not direct upgrades. If this isn't possible, why not? I would imagine folks would rather upgrade an OS than deploy new for things like Domain Controllers, infrastructure servers, or even client OS like Windows 8 to Windows 8.1.
  3. @p4ntb0y: "I was told that HP would not bother with winpe 2.0 until longhorn comes out, which is silly as its obvious that m$ are pushing for winpe 2. :-(" Once Longhorn has officially released, we should have the PSP, Insight Manager Agents, and tools for our SmartStart Scripting Toolkit. I haven't asked around, but I would not imagine official WinPE 2.0 support until we have a version of the SSSTK that supports WinPE 2. Keep in mind that Longhorn is just now coming out as an RC build, and not every vendor supports Longhorn on their servers. Our support for Longhorn, and quite frankly WinPE 2.0, is in Beta. WinPE 2 is bundled in the WAIK for Vista (and Longhorn when released) distribution. For now, we only officially support WinPE 1.6 (WinPE 2005) with our SSSTK and Rapid Deployment Pack (RDP) solutions.
  4. I was able to get WinPE2 booting on a DL585 G1 and DL380G4 without incident. Did you follow the steps I outlined above? I do not believe tech support will assist you, as we do not officially support WinPE 2.0 until we release RDP with WinPE 2 support. Feel free to PM me and I'll reply with my email address and we can converse via email.
  5. I got networking to initialize (although within a VM.) Here is the batch file I use to create the ISO: makeiso.cmd: @ECHO OFF SET WINPE2SOURCE == "c:\winpe2_x86" cd %WINPE2SOURCE% ECHO.Moving winpe.wim to ISO\ folder move winpe.wim ISO\sources\boot.wim ECHO. ECHO.Creating ISO image... oscdimg -n -bc:\winpe2_x86\etfsboot.com c:\winpe2_x86\ISO c:\winpe2_x86\winpe2_x86.iso ECHO. Echo.Moving winpe.wim back to original location move ISO\sources\boot.wim .\winpe.wim The problem was that in the \ISO\Sources directory, a boot.wim file already existed. However, it was the original PE image that comes with WAIK (which bootmgr is looking for boot.wim in the Sources folder in the ISO image.) My script will move the modified winpe.wim image to \ISO\Sources, compile the ISO, then move it back. I was able to bring up the network and access hosts.
  6. I'm wondering if you can boot into your PE image and locate the bxvbdx.sys in \Windows\System32\drivers. If not, then there is an error in the build process (the same that I'm running into.) It appears that when the image boots, it actually boots the boot.wim file located in the \ISO\Sources directory within the WinPE build location on your PC. I'm working to see if indeed this is the case.
  7. I was doing some research on a particular WinPE 2.0 error I was experiencing, and came across this forum. I haven't tested my WinPE package yet, as I'm preparing to test with RDP 3.50 and our newest generation of systems. What happens if you simply add a new folder in our mount directory that contains the extracted components of cp006316, and run drvload within WinPE? You can then use devcon to list the loaded drivers (I'm assuming here as you could use devcon in WinPE 1.6.) I have seen reports that peimg doesn't properly embed some drivers properly. I'll be testing my image the remainder of the week with our BL465's and BL480's that I have in a lab.
  8. We have released a beta version of the Proliant Support Pack (PSP) v7.65. You can read more on it here For the 32-bit beta PSP 7.65: ftp://ftp.compaq.com/pub/softlib2/softwar....65.lh.i386.exe For the 64-bit beta PSP 7.65: ftp://ftp.compaq.com/pub/softlib2/softwar...7.65.lh.x64.exe You will need the following packages: cp006277.exe cp006284.exe cp006316.exe cp006913.exe cp006924.exe cp006926.exe cp007054.exe cp006258.exe Extract the packages to c:\psp7.65, make sure that your winpe image is mounted, and then run the following commands: peimg /inf="C:\psp7.65\cp006284\cpqasm2.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006913\lsi_scsi.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006924\lsi_sas.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006926\hpcissx2.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp007054\cpqcisss.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp007054\hpcisss.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006277\CpqCiDrv.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006258\hpqilo2.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006316\bxvbd.inf" c:\winpe_x86\mount\Windows peimg /inf="C:\psp7.65\cp006316\bxnd.inf" c:\winpe_x86\mount\Windows Now, you would only really need the cp006316 package, as it contains the necessary drivers you need to get networking to work. I would suggest the other packages (especially cp006284, cp006258 and cp006277) if you are going to use Altiris Deployment Solutions or HP RDP 3.50, or you want the ability to use hponconfig to configure the iLO2 management processor.
×
×
  • Create New...