Jump to content

WinPE 2.0 and Windows XP


Recommended Posts

Hi all

After installing Windows XP via winnt32 i get a chkdsk error when i execute

chkdsk c: under Windows XP.

I get the same error when I try do deploy a sysprep’ed based XP

Image via Imagex. The XP image works fine on the master PC without error,

until I deploy it to other PC’s via Imagex and WINPE2.0.

When i deploy the same WIM Image via WinPE2005 it works fine.

i have attached a picture with the error.

Anyone know a fix for that ?

I think it has to do with the new format utillity in PE2.0 :realmad:

Anyone knows if a 3rd party format utillity exist for WinPE ?

I have tried execute the PE2005 format utillity under WinPE2. But i

can't start it.




Edited by kyor
Link to comment
Share on other sites

  • 1 month later...

I am the creator of the Thread "Installing Winxp via winnt32 under Winpe v2.0 (Vista PE)" and i

always use this workaround. Otherwise i can't install Windows XP :wacko:

I bet when you create and format your partition with winpe 2.0 (diskpart) and use

after that imagex, you have this problem, too.



Edited by kyor
Link to comment
Share on other sites

are you using Format directly or are you using the sub-command format from within diskpart?

EDIT: I just tested on a box with a Win2k3 install, and the drives were formated via diskpart format command. I did see the same error, but it went away when I ran a "chkdsk c: /f" command.

Will have to see if there is a fix for this, I hate to have to use a workaround.

Edited by Jazkal
Link to comment
Share on other sites

It doesn't matter whether you use the diskpart format command or the format.com.

Both methods produce this error.



After chkdsk c: /f i become sometimes a new error message

Fehler in Volumebitmap werden berichtigt.

Windows hat Probleme im Dateisystem festgestellt.

Führen Sie CHKDSK mit der Option /F (Fehlerbehebung) aus, um die Probleme zu


Translate form german to englisch

Correcting errors in Volumebitmap.

Windows found Problems in Filesystem.

Run CHKDSK/f to correct the error.

Edited by kyor
Link to comment
Share on other sites

  • 2 months later...
  • 10 months later...

I know this is an old topic, but I had to revisit the issue recently, and found that Microsoft had released a KB article on the topic:



This problem occurs when the following conditions are true:

• You use a Windows Vista-based computer to format the NTFS volume.

• You run the Chkdsk.exe tool on a computer that is running Windows XP or Windows Server 2003.

This problem occurs because of the differences in the uppercase file between Windows Vista and the earlier versions of the Windows operating systems.


When you use the /f switch together with the Chkdsk.exe tool, the Chkdsk.exe tool updates the file system to reflect the uppercase file that the current operating system uses. You can safely ignore the error message that is mentioned in the "Symptoms" section. The error message does not indicate a problem with the file system.

Link to comment
Share on other sites

Thanks for your info Jazkal.

It is sad that i informed Microsoft in January 2007 about this problem and they never give me a real solution.

Edited by kyor
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...