Jump to content

Zonealarm Showing Popping up errors in silent


Recommended Posts


I manged to get Zonealarm Security Suite to work in silent mode, but it tends to show a error message (distorting my unattended installation)

This is the error Message.

Could not find config file C:\Documents.

I assume its trying to locate C:\Documents and Settings\...

but I am unsure as to what the config file is or looks like.

Please help :thumbup

Link to comment
Share on other sites

"%CDROM%\Software\zonealarm\zapSetup.exe /s /i /noreboot /lickey xxxxxxxxxxxxxxxxxxxxx %CDROM%\Software\zonealarm\yourconfig.xml" /f

Could you please provide some more information on the yourconfig.xml file ?

I am trying to auto-install ZoneAlarm to a different than the default folder and I'd like the shortcuts in another folder, as well...



Link to comment
Share on other sites

Its already posted before... but ok..

in windows , open zonealarm go to the overview tab , and preferences.

hit the backup button under "backup and restore security settings"

Use that as your config , you might configure your zonealarm settings before you backup.

"%CDROM%\Software\zonealarm\zapSetup.exe /s /i /noreboot /lickey xxxxxxxxxxxxxxxxxxxxx %CDROM%\Software\zonealarm\yourconfig.xml" /f

Use like this... have fun

Link to comment
Share on other sites

  • 1 month later...

Couldn't tell if this was resolved for sure...

anyway, I use the free version... but I was thinking that since most program's store the registration key in the registry you could prolly capture the registration info as its written to the registry and put it in a reg file using RegShot (etc). Then call the registration file through your script.. I've gotten a few stubborn apps to install silently this way without even needing AutoIt. :D

Here is an example that should work from any folder as long as it contains

the CMD file itself, the installer, and "registration.reg"

<edit> Just tried a similar script directly from cd (w/o copying files to HDD) and didn't work during ua install... but I think its just how I set up my scripts - i.e. using a reg file to enter license keys *should* still work

<edit 2> I think the reason it didn't work last time was I forgot to add (escaped) quote from RunOnceEx when adding the path to silent_install.cmd ie (should be "\"%pathto%\silent_install.exe\"" /f rather than "%pathto%\silent_install.exe" /f ) since I forgot to take the spaces outta my path... :o

: Sets "thisdir" to directory that .cmd is in
SET thisdir=%~d0%~p0

:Adding Registration Info to the Registry
IF EXIST "%thisdir%\registration.reg" (START /WAIT REGEDIT /S "%thisdir%\registration.reg")

: Installing Silently (using Free version for the example)
IF EXIST "%thisdir%zlsSetup_61_744_000_en.exe" (START /D"%thisdir%" /WAIT zlsSetup_61_744_000_en.exe /S /noreboot)

Edited by spiritpyre
Link to comment
Share on other sites

  • 1 month later...

Having the same problems as the OP, getting that error message using either the switches or using an AutoIT script.

I wouldn't post unless I wasn't having any joy as I usually get the answer from a search, and i've managed to get the rest of my unattended install working fine that way. Its just ZoneAlarm giving me gip now :no:

I'm talking about the free ZoneAlarm, and I downloaded whichever version is current as of today.

This is my current switch:

zlsetup.exe /s /i /noreboot

I have also created and AutoIT script and tried that but I still get the error.

If there's no way around it then i'll just dump the .exe to C:\ and then perform a manual install once everything else has finished. :}

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...