Jump to content

Solution for Norton SystemWorks 2005


Recommended Posts

Finally, a definitive solution (hack?) for Norton SystemWorks 2005 custom unattended install.

Brief history of the problem:

As many of you know, there are numerous threads asking how to do an unattended install with NSW 2005. Now, out of all of these threads, the best advice is to use the following commandline:

NSWSETUP.EXE /O REBOOT=ReallySuppress /qb-

Unfortunately, that causes NSW to install pretty much darn near everything. Now, that may work for some people, but there are several threads asking how to do this with a custom install.

Until now, the best way to do this was to just delete the unwanted components... well, that worked good for most things, but not all things (such as "UnErase" and "UnFormat" -- I like my recycle bin just how it is, thank you very much).

So, after lots of playing around over the past few days, I have come up with a solution... finally.

First, you will need ORCA to edit a MSI file with. This utility can be found in the Microsoft Platform SDK (OS Independent). Install the SDK (the only component you really need to install is Microsoft Windows Installer SDK\Tools), then browse to the bin folder in the install path (default is C:\Program Files\Microsoft Platform SDK\Bin) and run the ORCA.msi file to install ORCA.

Second, you'll probably want to run the NSW installer in a VM or something to capture the log file (%temp%\Norton SystemWorks 2005 <date> <time>.log). Make sure that you do this install just as you want it to be in the end (same components). Basically, treat it like you would if you were recording an InstallShield script (setup -R). In this file, you should search for "NU\NU.MSI". After you find it, go down about 28-30 lines to find a line that starts with "MSI (s) (DC:20): Command Line: ". (Some of that may be different, the important part is that it is the first line after the "NU\NU.MSI" that you found that starts with "MSI" and contains "Command Line".) In this line, there is a section that starts with "REMOVE", copy all of the text after that into something that you can hold onto for a moment. This is a list of all of the NU components that are not going to be installed as part of NSW. Weird, I know... but that's life with Symantec.

Third, browse to your Unattended folder and open it up to your NSW location. Once there, open the "NU" folder and make a backup copy of NU.MSI (or you can just plan on copying it back from your CD if you mess it up). Now, right click on the NU.MSI file, and select "Edit with Orca".

Now, we need to make two changes to this file to override what the setup program will be passing into it by default during your unattended setup.

Change 1:

Locate the table titled "CustomAction" in the left-hand pane and click on it. In the right-hand pane, right-click and select "Add Row". Enter the following data:

Action: SetRemovedComponents1
Type: 51
Source: REMOVE
Target: <paste the string you copied from the log file here>

Now, add another row that is exactly the same, but has an Action value of SetRemovedComponents2

Change 2:

Locate the table titled "InstallExecuteSequence" in the left-hand pane and click on it. In the right-hand pane, right-click and select "Add Row". Enter the following data:

Action: SetRemovedComponents1
Condition: <leave blank>
Sequence: 150

Now, add another row with the following data:

Action: SetRemovedComponents2
Condition: <leave blank>
Sequence: 950

(We have to enter this stuff twice because I'm too lazy to figure out exactly where the code needs to go to only have it in there once... hey, I've been working on this bugger all week--give me a break! If someone wants to play with it to figure it out, by all means, be my guest.)

Now, save the MSI (File -> Save, or just exit the program) and use the following command line in your installation script (whatever type it may be)

One last thing, and we're set to go. Currently, this is going to have issues with the product key. However, if you enter the product key into the registry first, everything comes out nice and smooth. To do that, enter the following into an empty text file and save it as NSW.REG (replacing the Xs with your key, of course):

For Norton System Works 2005

Windows Registry Editor Version 5.00


For Norton System Works 2005 Premier

Windows Registry Editor Version 5.00


<add the NSW.REG file to your registry, however you do that>
<PathToNSW>\NSWSETUP.EXE /O REBOOT=ReallySuppress /qb-

Ta da! You should be done and working... give it a try in a VM to make sure.

For those of you who are interested, I install the following components:

Anti Virus

Disk Doctor


Speed Disk

Explor Shell Extensions

Which leaves me with a REMOVE line of (all on one line, of course):



Now, if you want to disable NAV, you'll have to edit a different MSI file. Unfortunately, NSW blows up if the NAV\NAV.msi file isn't there. I tried making a dummy MSI installer, but NSW threw a fit about that one too. So, we get to rip parts out of the NAV.msi file.

So, open up NAV.msi in ORCA. The first table that you're going to play with is the 'Binary' table. There are two files in here that can be deleted. They are 'Callreginst' and 'Callsttginst'.

Next, go to the 'CustomAction' table. In this table, you need to KEEP the following rows (delete all of the others):










Now, go to the 'InstallExecuteSequence' table and remove all of the entries in it. Yup, every last one (this is what keeps the MSI from actually DOING anything when it is called).

Next, go to the 'SymNestedFeature' and 'SymNestedInstaller' tables and remove everything EXCEPT for the one row in each table that starts with 'this'.

Now, just save the file out and remove everything else in the NAV folder (including any subfolders). You can remove the VIRUSDEF folder from the SystemWorks root as well.

FYI, this technique seems to work as well for NIS, though I can't find a shortcut to LiveUpdate anywhere in my Start menu (accessable through the NIS control panel). Definately don't use this if you're installing *both* NIS and NSW unless you don't want NAV installed at all. If this is the case, leave NIS alone (it will install NAV) and use this technique on the NSW install (which must run *after* NIS). This *should* cause the NSW installer to uninstall NAV and then run the 'custom' MSI that you've edited. No promises though, it's way past my bedtime and I don't know when I'll actually get around to testing it.


Open the NORTONGHOSTNT.MSI (and after that one, the GHOST.MSI) file in ORCA and naviate to the 'InstallExecuteSequence' table and remove all of the entries in it. Yup, every last one (this is what keeps the MSI from actually DOING anything when it is called).

Ghost shouldn't give you any hassles now, and won't actually install.


CleanSweep shouldn't give you any problems if you don't want it installed, because it is unselected by default. However, I had a request by someone who does want it, so here it is.

The easiest way to do it is to actually make it a separate install. Use the command line:


to launch the installer, and make sure that you do this AFTER installing the main body of NSW (at that will install the common libraries, etc.).

Enjoy, and good luck!

P.S. As a side note, you may get an error or two if you try to uninstall. Just click 'ignore' and everything seems to come out allright. Once, I had a couple of NU shortcuts that didn't get removed, but they no longer pointed to anything <shrug>.

Edited by gosherm
Link to comment
Share on other sites

  • 3 weeks later...


i used the same process that gosherm tell us in simply mode.. but there is a problem...

so.. i used only the first of the two disk of installation of NSW 2005 premium..

i've copied all the file and the directory except NAV (because i use Kasperky Personal..)..

i've found in the file .log the excactly row for nu.msi...

i've copied the entire part after ERASE= (until the next command..)

i did all the step for the file nu.msi with orca...

insert the rows:

regedit /S %systemdrive%\INSTALL\nsw\nsw.reg

start /wait %systemdrive%\install\nsw\NSWSETUP.EXE /O REBOOT=ReallySuppress /qb-

in the file nsw.cmd

and burn my disk...

but when star the unattended installation of nsw.. i receive an error of installation!!!

why this???

there is only this method for installing norton systemworks???

thanks a lot

Link to comment
Share on other sites

please wait a minute.. i reinstall now the program..

so.. the error is: (i translate for you in eglish from italian language..)

To continue, please insert Norton SystemWorks 2005 Premier CD-ROM.


i think that the error come because there isn't NAV directory.. but how can i say to the installation program that i don't want install NAV??

I want to install only:

Norton Utilities (without wipe info and unformat program..)

Norton CleanSweep

thanks a lot

Edited by orei
Link to comment
Share on other sites

this is the row of the log that i've found..

MSI (s) (38:2C) [14:28:58:578]: Command Line: SYMSETUP=1 ARPSYSTEMCOMPONENT=1 REBOOT=ReallySupress PARENTINSTALLDIR=C:\Programmi\Norton SystemWorks INSTALLDIR=C:\Programmi\Norton SystemWorks\Norton Utilities NU_PROGRAM_MENU=C:\Documents and Settings\All Users\Menu Avvio\Programmi\\Norton SystemWorks Premier\Norton Utilities SUITEINSTALL=1 ADDLOCAL=ALL REMOVE=Wipe_Info,Norton_Registry_Tracker,Norton_Registry_Editor,DOS_Applications,UnErase_Wizard,Nort

on_File_Compare,Image32,Norton_Optimization_Wizard CURRENTDIRECTORY=F:\UTILE\altri programmi\Utiliti di emmergenza\Norton System Works 2005\Norton system works 2005 Cd1 CLIENTUILEVEL=3 CLIENTPROCESSID=3776 CURRENTMEDIAVOLUMELABEL=WXPSP2_0905

i used only this text:



in the nu.msi, i've added the text that you wrote in your post


Link to comment
Share on other sites

so.. now there is a big big problem... nooooooooooo!!!!!!!

if i install the packet with:

NSWSETUP.EXE /O REBOOT=ReallySuppress /qb-

i receive an answer, that say me that can't do the installation process, because i need to uninstall NSW that i've installed before... but i didn't installed anithing!!!

Instead.. if i start the installation with NWSETUP.EXE... so.. normal... te installation go well...


thanks a lot

Link to comment
Share on other sites

i've analyzed the problem...

if, when i launch the installation process, there is NAV directory (with your modded nav.msi file.. and with or without all other files..), the process will terminate with an error...

if, when i launch the installation process, there isn't NAV directory (because i've renamed it in NAVe for example..), the process start, but ask me the nav.msi file in the middle of installation.. now i say to the program where is the file, and the installation finish fine!

So.. but if i want a complete unattended installation?? how can i do???

Because i saw that you are a GURU of unattended windows etc.. i've another problem with the last program..

Nero 7 Premium Retail Version (not beta..)

In beta version.. the command /norestart work fine.. and the computer doesn't restart.. but in the new retail version, the command /norestart didn't work..

but the file .msi is the same!!

if you want.. and you can.. this is the topic where i talk about my problem:


Thanks a lot!!

Link to comment
Share on other sites

  • 2 weeks later...

Suppose gotta take a better look when I have more time

But is there a way to configure the MSI to install to the %Systemdrive% ? By accident was using it on a mates computer where there was no C:\ (don't ask me why :P ) and the NSW install method failed, since it automatically tried to install to C:\

Link to comment
Share on other sites

  • 3 weeks later...
But is there a way to configure the MSI to install to the %Systemdrive% ?

@SyKik -- Is that a problem with my custom NAV.msi? [edit]Well, regardless. No more custom MSI from me. You get to edit your own now. Check out the first post of the thread for updated instructions.[/edit]

@orei -- I'll be happy to take a look at Nero when I get my hands on it. I suppose that today's the 26th and I can go see about d/l'ing a upgrade from Ahead now. Of course, this subject will get relocated to an appropriate (existing?) thread. [edit](*Blasted* software developers... the download was *supposed* to be available today, the 26th. But no... it's NOW available on Nov 2. What a pain. Actually, I probably shouldn't blame it on the developers, it's probably somebody in the QA dept. saying 'I don't think we should ship with this minor bug' or something like that. Not that I've ever done that. But then again, at my workplace, my supervisor just tells me (jokingly, of course) to shut up and get to work if I say something like that -- "It's not a bug!")[/edit] <I'll add link here after I post in it.>

@all -- Sorry I've been pretty swamped with work and stuff lately, I should have a bit of time over the next week or so to look closer at this. [edit]Ok. Check the first post, instructions should be working this time around. Let me know if there's still any bugs.[/edit]

Edited by gosherm
Link to comment
Share on other sites

Hi There,

Well, I have followed the new instructions posted. Everything went well to create the new install. I Removed NAV as I like Symantec Corporate Instead (Less Bulky and MUCH faster).

I Will try the install and see if it works without any hitches.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...