Jump to content

DNS errors


 Share

Recommended Posts

I had slow connectivity problems to my network so i ran netdiag on my server. It produced the follwing report:

   Computer Name: ********
   DNS Host Name: **************.local
   System info : Microsoft Windows Server 2003 (Build 3790)
   Processor : x86 Family 15 Model 31 Stepping 0, AuthenticAMD
   List of installed hotfixes :
       Q147222


Netcard queries test . . . . . . . : Passed
   [WARNING] The net card '1394 Net Adapter' may not be working because it has not received any packets.



Per interface results:

   Adapter : Local Area Connection

       Netcard queries test . . . : Passed

       Host Name. . . . . . . . . : **********
       IP Address . . . . . . . . : 192.168.1.100
       Subnet Mask. . . . . . . . : 255.255.255.0
       Default Gateway. . . . . . : 192.168.1.1
       NetBIOS over Tcpip . . . . : Disabled
       Dns Servers. . . . . . . . : 192.168.1.100


       AutoConfiguration results. . . . . . : Passed

       Default gateway test . . . : Passed


       WINS service test. . . . . : Skipped
           NetBT is disable on this interface. [Test skipped].


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Skipped
   There are no interfaces that have NetBT enabled. [Test skipped]


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Skipped
   There are no interfaces that have NetBT enabled. [Test skipped]


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Failed
      [FATAL] File \config\netlogon.dns contains invalid DNS entries.    [FATAL] No DNS servers have the DNS records for this DC registered.


Redir and Browser test . . . . . . : Skipped
   There are no interfaces that have NetBT enabled. [Test skipped]


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Skipped


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
   No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

   Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

Obviously this is causing the error:

DNS test . . . . . . . . . . . . . : Failed

[FATAL] File \config\netlogon.dns contains invalid DNS entries. [FATAL] No DNS servers have the DNS records for this DC registered.

Ive checked around but cant find a resolution. Can anyone advise how to resolve this issue?

Thannks ppl as always

Link to comment
Share on other sites


You got a FAIL on the Netdiag test, use the log file to determine the problem record. You can use Netdiag /fix to apply the contents of the Net-logon.dns file to DNS again. If this resolves the problem and it doesn’t reoccur, then all’s well. If the problem happens again, you’ll have to do more digging.

Link to comment
Share on other sites

Just before you do what Marsden has said try this first:

Make sure the zone has Dynamic Updates or Only secure option selected. (Go into DNS and right click select properties)

Stop the netlogon and the DNS service (at cmd prompt type net stop netlogon and net stop dns)

Go to %systemroot%\system32\config folder and then delete the netlogon.dns and netlogon.dnb files

Restart DNS and netlogon

Run netdiag /fix

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...