Jump to content

XP Home unnatended.. i get Choice of OS on bootup?


Recommended Posts


I have a XP SP2 HOME cd i made for work... everythings fine, all apps working nicely etc, but one problem

i set it so that it asks me for partition info ( i ALWAYS delete the partitions so it says "unpartitioned space")

then format NTFS FULL

now all goes fine... after instal is complete, the pc reboots ...

now here it asks for choice of OS

both are WIN XP HOME, and whichever i press brings up the same windows, which isnt really a problem, just that it waits there for 30 seconds before continuing loading windows

now is there anyway i can fix this in my cd so that it doesnt show 2, or if not, is there a way too change the default "display choice of OS from 30 seconds to 1" without manually changing it after the instal is done

here is my winNT.sif incase something is wrong there


   KeyboardLayout="United Kingdom"









DefaultStartPanelOff = No







Link to comment
Share on other sites

If you always reformat why don't you specify it to do that in your winnt.sif file automatically?



As far as the dual boot if you are formatting the entire drive you should only see one boot however that option should be able to bypassed with your boot settings. You can check your boot options in msconfig or from a cmd prompt with bootcfg it should look something like this.

Boot entry ID:   1
Friendly Name:   "Microsoft Windows XP Professional"
Path:            multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
OS Load Options: /fastdetect

Anything more than this would indicate that you have not formated the entire drive, have installed multiple os or have a problem with your boot setup.

Link to comment
Share on other sites

kc_ Here is something else you can try.

From your desktop

1 Right click my computer

2 Click the "advanced" tab

3 In the box near the bottom labled "Startup and Recovery" click the "settings" button

4 Select the drop down box labled "Default operating system" to see what is listed. There should be only one OS.

Also you can modify the "time to display list of operating systems:" to less than 30 secs here. I would not recomend lowering the one for recovery options. This is the screen that gives you safe mode options at startup in the event of a crash during boot.

If this does not fix your problem please click the edit button (DO NOT CHANGE ANYTHING MANUALLY UNLESS YOU SURE YOU KNOW WHAT YOUR DOING) which will open your boot.ini file. Copy it, post it and I will take a look.

Hope this helps...

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...