Jump to content

WinPE Diskpart problem


Recommended Posts

I hope someone can help with this urgent issue.

I use WinPE on a USB Thumb drive to install 2003 server. A quick summary of the process

Boot from USB drive using syslinux bootloader (menu driven loader)

Boot WinPE ISO via Grub Loader (syslinux will not load the iso)

From WinPE, use Diskpart to Clean, Partition and make active HDD

Format HDD (Logical Drive) to NTFS

Copy over bootfiles (NTDetect, NTLDR etc etc)

Copy over sysprep image

Reboot machine and let it install from sysprepMy linked Image

All this works fine on a machine running RAID 5 over 3 SAS disks; however the problem i'm having is getting this to work on a machine running RAID 5 over 3 SCSI disks. (both have only 1 logical drive)

It partitons the Logical Drive and marks it as active but when the system reboots, it sticks on 'Error loading operating system'

If I run the same process but instead of using a USB device, run WinPE from a CD (and altering the DiskPart commands as required), it will work fine. In addition to this, if I run the above steps from a USB device twice, it will work. I have tried the MBRFIX tool from Here to no avail, I have also tried the Vista Bootsect.exe tool to no avail.

Here are the Diskpart commands I am running (they are all batched)

Booting WinPE from CD

select disk 0


select volume 0

assign letter=E: <<< CD Drive

select disk 0 <<< Logical Drive

create partition primary

assign letter=C:

select partition 1



format c:\ /fs:NTFS /Q /Y

This will work on both the SCSI and SAS RAID 5 from CD

Booting WinPE from USB

select volume 1

assign letter z: <<< USB Drive

select disk 1 <<< Lofical drive, now 1 because USB takes 0


create partition primary

assign letter=C:

select partition 1



format c:\ /fs:NTFS /Q /Y

This works on the SAS RAID 5 from USB but not the SCSI RAID 5, it hangs on 'Error loading operating system'

It reports that it has succeeded in all steps and if I boot off the USB drive again and check the partition, everything seems fine.

If I run the same procedure again, it will work fine

Before anyone asks, I have checked that the Disks, Volumes and partitions I am referencing in the diskpart commands are infact the correct ones.

Please help as this is very urgent...

Thanks in advance

I have since discovered this also happens to the SAS drives. It only occurs when the RAID set gets deleted and recreated.

Edited by pr1ngl3
Link to comment
Share on other sites

  • 3 weeks later...

Edit the registry of your PE before running the diskpart command:

Windows Registry Editor Version 5.00

@="Alignment Settings in Bytes"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...