Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
NOTS3W

Need help to set up sharing unattended

Recommended Posts

I have another open thread under Networks and the Internet about sharing my Windows 7 drives. This isn't a double post, but the reverse question. How to share the drives on my XP computer (via unattended installation of Windows XP Home). I can get part way there, but the drives are not accessible.

My XP computer has two drives. One (C:) is on an on-board IDE controller. The other (D:) is on a SATA add-on card. The computer name is Saturn. Both drives work perfectly on the local machine so I don't think this has anything to do with drivers or hardware. I've tried both of these sets of commands in GuiRunOnce.cmd:

net share "Saturn C"=C:\ /UNLIMITED
net share "Saturn Data"=D:\ /UNLIMITED

rmtshare \\Saturn\"Saturn C"=C:\ /grant everyone:full
rmtshare \\Saturn\"Saturn Data"=D:\ /grant everyone:full

In each case, the drive icons change to show the hand under the drive, but when I try to access either drive from the Windows 7 machine, I'm prompted for a network user name and password.

On the properties window for either drive, it appears that I still need to turn on sharing. If I "...understand the security risks..." and "Just enable file sharing," everything comes up checked with the share name set above. Then I can access the drive without problems.

What do I need to do in addition to using one of the sets of commands above to automate sharing?

A couple of other things:

I've added the Security tab (Security Configuration Editor) but did not disable simple file sharing. On the Security tab of the C: drive, I have a list of users and groups: Admins, Owner, System, Users and "Everyone". The Permissions for "Everyone" are blank on this drive. On the D: drive, I have only one user group: "Everyone" with full control. I assume Windows is setting default permissions for the system (C:) drive and not adding additional permissions for the second (D:) drive. If I manually turn on sharing for the D: drive, my Windows 7 computer has full access to all folders and files. When I do that for the C: drive, I can see the folders but I can't access them until I manually give "Everyone" full control on the drive.

I've also tried moving the share commands to a separate process after Windows is completely installed just in case Windows is overriding my settings. No difference. I still have to manually turn on sharing to share the drives.

Share this post


Link to post
Share on other sites

you need to use calcs to set/change permissions via the command line

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...