Jump to content

Strangest thing: 7-Zip Switchless Installer


ajua
 Share

Recommended Posts

I was finishing my new switchless installers for the updated version of Windows Live Essentials. The only thing left was Windows Live Writer.

When I tested all the installers, everything worked as expected except for Writer. I got an error because the file was trying to launch Mail.msi and the file inside the archive was Writer.msi so I thought I made a mistake and redid the installer for Writer.

I changed the config.txt info to launch Writer.msi instead of Mail.msi but when I run the installer, I still get that Mail.msi was not found.

I have tried to make the installer from scratch, including a new config.txt file and newly made .7z archives. The problems is the same.

In my laptop, I tried to make them and the same error occurs. There is no way I can make the installer to launch Writer.msi instead of Mail.msi.

To make things worse, if I extract the config.txt using 7-Zip Archive Splitter and open the file in notepad, the text says Windows Live Mail and the file to launch is Mail.msi when the only config.txt I have is for Writer and there's no way that text about Mail should be there.

This is one the strangest things that had happened to me.

Any ideas? I'm going to bed right now I will try tomorrow on a third computer.

EDIT: I forgot to mention that I'm using (as always) the modified SFX module. I make the exe files using copy /b in a command prompt.

Edited by ajua
Link to comment
Share on other sites


I don't use the internal 7-zip sfx module commands.

Why don't you use a batch file to install all those msi files?


;!@Install@!UTF-8!
InstallPath="%temp%\\WindowsLive"
RunProgram="hidcon:Install.cmd"
Delete="%temp%\\WindowsLive"
GUIMode="2"
;!@InstallEnd@!

Link to comment
Share on other sites

I don't use the internal 7-zip sfx module commands.

Why don't you use a batch file to install all those msi files?


;!@Install@!UTF-8!
InstallPath="%temp%\\WindowsLive"
RunProgram="hidcon:Install.cmd"
Delete="%temp%\\WindowsLive"
GUIMode="2"
;!@InstallEnd@!

I've made countless installers using the modified module with RunProgram for MSI files . The weird thing had to do with the config.txt because no matter what I put in it before making the EXE with copy /b if I tried the installer or extracted the config.txt from the EXE it will show Mail.msi instead of Writer.msi and the installer will throw an error.

I just moved the files to a desktop folder and tried to build the installer again and it worked.

Don't ask me why, but this solved that weird problem with the Windows Live Writer switchless installer. I've extracted the config.txt using the Archive Splitter and it now shows the commands and text that is supposed to be there...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...