Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
xpman

Blue screen in vm with iastor.sys 9.6.0

Recommended Posts

I had integrated the Intel storage drivers with the version 8.9.0 a while ago. Using Fernando's enhanced driver pack for my ICH10 chip, this worked perfectly.

When switching to the 9.6.0 version, I started getting blue screens in my virtual test machine (STOP 0x7E). This happens during textmode setup right after the drivers are have been loaded, when the actual setup is started (EULA page, etc.).

After some frustrating trials, I found iastor.sys to be the problem. Using the 8.9.0 sys file, setup continues.

To avoid having to use different versions of my DVD for testing and real installations, I would appreciate it if I could indeed use the latest drivers also with my VM. I have attached my txtsetup.sif snippet for the drivers that I made based on Fernando's txtsetup.oem.

What I find strange is that the sys file should actually be loaded at all in a VM since the corresponding hardware is not there; but why else would I get a blue screen with one sys file and not the other?

[SourceDisksFiles]
iaStor.sys = 1,,,,,,3_,4,1



[HardwareIdsDatabase]

; iaAHCI.inf
PCI\VEN_8086&DEV_2681&CC_0106 = "iaAHCI_ESB2"
PCI\VEN_8086&DEV_2652&CC_0106 = "iaAHCI_6R"
PCI\VEN_8086&DEV_2653&CC_0106 = "iaAHCI_6M"
PCI\VEN_8086&DEV_27C1&CC_0106 = "iaAHCI_7RDH"
PCI\VEN_8086&DEV_27C5&CC_0106 = "iaAHCI_7MMDH"
PCI\VEN_8086&DEV_2821&CC_0106 = "iaAHCI_8RDHDO"
PCI\VEN_8086&DEV_2824&CC_0106 = "iaAHCI_8AHCI"
PCI\VEN_8086&DEV_2829&CC_0106 = "iaAHCI_8MEM"
PCI\VEN_8086&DEV_2922&CC_0106 = "iaAHCI_9RDODH"
PCI\VEN_8086&DEV_2923&CC_0106 = "iaAHCI_9AHCI"
PCI\VEN_8086&DEV_2929&CC_0106 = "iaAHCI_9MEM"
PCI\VEN_8086&DEV_3A02&CC_0106 = "iaAHCI_10DDO"
PCI\VEN_8086&DEV_3A03&CC_0106 = "iaAHCI_10AHCI"
PCI\VEN_8086&DEV_3A22&CC_0106 = "iaAHCI_10R"
PCI\VEN_8086&DEV_3A23&CC_0106 = "iaAHCI_10AHCI"
PCI\VEN_8086&DEV_3B29&CC_0106 = "iaAHCI_PCHM"
PCI\VEN_8086&DEV_3B2F&CC_0106 = "iaAHCI_PCHM_1"
PCI\VEN_8086&DEV_3B22&CC_0106 = "iaAHCI_PCH"

; iaStor.inf
PCI\VEN_8086&DEV_2682&CC_0104 = "iaStor_ESB2"
PCI\VEN_8086&DEV_2652&CC_0104 = "iaStor_6R"
PCI\VEN_8086&DEV_27C3&CC_0104 = "iaStor_7RDH"
PCI\VEN_8086&DEV_27C6&CC_0104 = "iaStor_7MDH"
PCI\VEN_8086&DEV_2822&CC_0104 = "iaStor_8R9R10RDOPCH"
PCI\VEN_8086&DEV_282A&CC_0104 = "iaStor_8ME9MEPCHM"



[SCSI.load]

; iaAHCI.inf
iaAHCI_ESB2 = iaStor.sys,4
iaAHCI_6R = iaStor.sys,4
iaAHCI_6M = iaStor.sys,4
iaAHCI_7RDH = iaStor.sys,4
iaAHCI_7MMDH = iaStor.sys,4
iaAHCI_8RDHDO = iaStor.sys,4
iaAHCI_8AHCI = iaStor.sys,4
iaAHCI_8MEM = iaStor.sys,4
iaAHCI_9RDODH = iaStor.sys,4
iaAHCI_9AHCI = iaStor.sys,4
iaAHCI_9MEM = iaStor.sys,4
iaAHCI_10DDO = iaStor.sys,4
iaAHCI_10AHCI = iaStor.sys,4
iaAHCI_10R = iaStor.sys,4
iaAHCI_PCHM = iaStor.sys,4
iaAHCI_PCHM_1 = iaStor.sys,4
iaAHCI_PCH = iaStor.sys,4

; iaStor.inf
iaStor_ESB2 = iaStor.sys,4
iaStor_6R = iaStor.sys,4
iaStor_7RDH = iaStor.sys,4
iaStor_7MDH = iaStor.sys,4
iaStor_8R9R10RDOPCH = iaStor.sys,4
iaStor_8ME9MEPCHM = iaStor.sys,4



[SCSI]

; iaAHCI.inf
iaAHCI_ESB2 = "Intel(R) ESB2 SATA AHCI Controller"
iaAHCI_6R = "Intel(R) ICH6R SATA AHCI Controller (added by Fernando)"
iaAHCI_6M = "Intel(R) ICH6M SATA AHCI Controller (added by Fernando)"
iaAHCI_7RDH = "Intel(R) ICH7R/DH SATA AHCI Controller"
iaAHCI_7MMDH = "Intel(R) ICH7M/MDH SATA AHCI Controller"
iaAHCI_8RDHDO = "Intel(R) ICH8R/DH/DO SATA AHCI Controller"
iaAHCI_8AHCI = "Intel(R) ICH8 SATA AHCI Controller (added by Fernando)"
iaAHCI_8MEM = "Intel(R) ICH8M-E/M SATA AHCI Controller"
iaAHCI_9RDODH = "Intel(R) ICH9R/DO/DH SATA AHCI Controller"
iaAHCI_9AHCI = "Intel(R) ICH9 SATA AHCI Controller (added by Fernando)"
iaAHCI_9MEM = "Intel(R) ICH9M-E/M SATA AHCI Controller"
iaAHCI_10DDO = "Intel(R) ICH10D/DO SATA AHCI Controller"
iaAHCI_10AHCI = "Intel(R) ICH10 SATA AHCI Controller (added by Fernando)"
iaAHCI_10R = "Intel(R) ICH10R SATA AHCI Controller"
iaAHCI_PCHM = "Intel(R) PCHM SATA AHCI Controller 4 Port"
iaAHCI_PCHM_1 = "Intel(R) PCHM SATA AHCI Controller 6 Port"
iaAHCI_PCH = "Intel(R) PCH SATA AHCI Controller"

; iaStor.inf
iaStor_ESB2 = "Intel(R) ESB2 SATA RAID Controller"
iaStor_6R = "Intel(R) ICH6R SATA RAID Controller (added by Fernando)"
iaStor_7RDH = "Intel(R) ICH7R/DH SATA RAID Controller"
iaStor_7MDH = "Intel(R) ICH7MDH SATA RAID Controller"
iaStor_8R9R10RDOPCH = "Intel(R) ICH8R/ICH9R/ICH10R/DO/PCH SATA RAID Controller"
iaStor_8ME9MEPCHM = "Intel(R) ICH8M-E/ICH9M-E/PCHM SATA RAID Controller"

Edited by xpman

Share this post


Link to post
Share on other sites

I'm having the same issue. I think that all of the drivers you list to load either through txtsetup.sif or textsetup.oem method get loaded into memory during the phase of setup enumerating the plug and play drivers.

I'm using a single image delivered with Windows Deployment Services that supports lots of different models of Lenovo and older IBM desktops and laptops. I need the new Iastor.sys for some of the newer models, and it works just fine for them, but it's giving some of the older machines a BSOD. Just like your issue the machine getting the BSOD doesn't even need the iastor.sys driver to begin with.

Share this post


Link to post
Share on other sites

This is indeed true, which is why you're seeing it even on a VM, OP. It's probably best to determine hardware (in a WinPE environment) before attempting to restore an image, and then inject the proper drivers for the hardware at that time. You could consider using MDT 2010 for this, but you would have to use flat-file or sysprep installs (not WIM image captures) to install XP from MDT-created media.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...