Jump to content

WSIM Catalog Generation Error

Recommended Posts

Searched a bit and only found errors pertaining to this & WDS/MDT, and the fixes didn't make sense for my scenario. All I did was take RTM, add RSAT MSU file as a package using DISM (/add-package) & add a file under the %windir%\security\templates. Ummount & commit and then try to open the image with WSIM and it always gives the same error with the following log:

3:57 PM : 
3:57 PM : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows OPK or Windows AIK User's Guide.
3:57 PM :
3:57 PM : System.ComponentModel.Win32Exception: The interface is unknown

Server stack trace:
at Microsoft.ComponentStudio.ComponentPlatformInterface.WimImageInfo.PreCreateCatalog()
at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageIn
fo offlineImageInfo)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)

I can open the original RTM file fine and force a catalog generation on it... but the new install.wim just won't work. All I wanted to see is if the new features would appear in the Foundation package since DISM added that package under the Windows Foundation...

I know I could just as easily enable them all using the /enable-feature of DISM, but I was curious.

I know WSIM can open custom images & catalog them (conclusion reached from my searches), I've just never gotten it to work on any custom images myself!

Any ideas?


Link to comment
Share on other sites

I have seen that error myself a couple of times. A reboot solved it.

Maybe there is something messing with the WIM filters or the image being committed and it wasn't saved/unmounted properly.

Are you using the latest WAIK? The Windows 7 RTM WAIK is already published at Microsoft website.

Link to comment
Share on other sites

Yeah, I had rebooted a few times, logged in locally as admin instead of my network admin account and I even uninstalled completely and re-installed with luck on resolving this issue. When I downloaded RTM, I downloaded the new WAIK as well to make and re-created my autounattend.xml from scratch to make sure.

I was able to get it working a few hours ago this morning by installing WAIK on the Windows 7 platform I was actually working on and it was able to generate a new catalog just fine. Seems my XP + WAIK is now screwed up with no solution on how to fix it aside from a format or maybe using a VM... sucks, but WAIK is an easy & fast install on W7, even if I have to re-install it everytime I re-test deployment heh.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...